Foros del Web » Programando para Internet » PHP »

Error en Apache+MySql al conectar

Estas en el tema de Error en Apache+MySql al conectar en el foro de PHP en Foros del Web. Estimado foro: Soy novato en esto de PHP y MYSQL, estoy intentando hacer una conexión a mi base de datos MySql. Tengo el siguiente codigo: ...
  #1 (permalink)  
Antiguo 16/02/2006, 09:38
 
Fecha de Ingreso: febrero-2006
Mensajes: 8
Antigüedad: 11 años, 10 meses
Puntos: 0
Sonrisa Error en Apache+MySql al conectar

Estimado foro:
Soy novato en esto de PHP y MYSQL, estoy intentando hacer una conexión a mi base de datos MySql.
Tengo el siguiente codigo:

<?php
$conexion = mysql_connect('localhost', 'root', 'root');
mysql_query($conexion,'SELECT * FROM articulo') ;
result = mysql_use_result(&mysql);
echo "¡Gracias! se ha efectuado la consulta.\n";
?>

Pero al ejecutar desde el Browser "Mozilla", me da el siguiente error:
Warning: Unexpected character in input: '\' (ASCII=92) state=1 in c:\appserv\www\pruebacon1.php on line 2

Parse error: syntax error, unexpected T_STRING in c:\appserv\www\pruebacon1.php on line 2

No entiendo que puede ser, ya me recorrí todo el manual de PHP, todo este foro y en todos los lugares me suena a que está bien escrita la línea de comandos.
Por favor si pudiesen ayudarme les estaría agradecido.
Saludos,
Gustavo
  #2 (permalink)  
Antiguo 16/02/2006, 09:53
Avatar de mauled  
Fecha de Ingreso: marzo-2005
Ubicación: Cd. de México.
Mensajes: 3.001
Antigüedad: 12 años, 9 meses
Puntos: 33
Pregunta

Te pido que cambies lo que tienes en las lineas 3 y 4 por esto
Código PHP:
<?
$mysql 
mysql_query($conexion,'SELECT * FROM articulo') ;
result mysqli_use_result($mysql) or die("Error");
?>
Comentanos si sigues teniendo error.

Última edición por mauled; 16/02/2006 a las 10:04
  #3 (permalink)  
Antiguo 16/02/2006, 10:02
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Revisa la documentación de PHP sobre uso de las funciones Mysql ..

www.php.net/mysql

tienes al reves algunos parámetros (en mysql_query()).

También te dejastes los $ en las variables que usas .. en otros lados pusistes & .. y usas "variables"? que no asignas (ese "supuesto": &mysql). En fin .. no sé si será un "error" al publicar el código en el foro .. pero si no es así, te invito a ver un tutorial de PHP más básico para que te manejes con uso de "variables" y las intrucciones PHP en general.

Un saludo,
  #4 (permalink)  
Antiguo 16/02/2006, 10:06
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Otro detalle ..

Menudo lio .. por un lado usas mysql_xxx() funciones y por otro pretendes usar mysqli_xxx() funciones?

O usas un grupo de funciones u otro .. pero no los dos. Si no te aclaras mucho con Mysql . .empieza por el uso de mysql_xxxx() funciones (que tienes muchos tutoriales y demás en la red) y luego ya te cambiarás (si usas PHP 5.x o superior y dispones de la extensión mysqlI instalada) al otro grupo de funciones.

Un saludo,
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 17:27.