Foros del Web » Programando para Internet » PHP »

error con el autenticator??

Estas en el tema de error con el autenticator?? en el foro de PHP en Foros del Web. Hace unos dias me descarge el autenticator de Cluster (por cierto se sale, mis felicitaciones Cluster y las gracias por prestar el código) y empleee ...
  #1 (permalink)  
Antiguo 05/04/2005, 12:41
 
Fecha de Ingreso: enero-2005
Mensajes: 15
Antigüedad: 12 años, 11 meses
Puntos: 0
error con el autenticator??

Hace unos dias me descarge el autenticator de Cluster (por cierto se sale, mis felicitaciones Cluster y las gracias por prestar el código) y empleee l sistema de autentificacion que empleba. Desde entonces lo estoy usando sin ningun tipo de problema con mozilla y firefox, pero a la hora de usarlo con internet explorer me da un error que no se arreglar de momento:
Me autentifico en la intranet, y navgo por las paginas que tienen permisos normales (me autentifico como administrador que en mi caso es nivel 0), y luego entro en las paginas que solo puede ver el administrador y directamente me saca de la intranet. Es extraño por que solo ocurre con internet explorer.
spero alguien sepa que ocurre. Un saludo y gracias.
  #2 (permalink)  
Antiguo 05/04/2005, 12:55
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Por defecto Autentificator (TM) XD .... gestiona el SID y su propagación en cookies (así ha de propagarlo PHP bajo session.use_cookies = ON minimo) ..

Ahora, si hay problemas en generación de esa cookie, el sistema (la validación de sesiones que se hace) actuará.

Revisa la configuración de tu navegador sobre el tema de cookies.

También podría existir algún conflicto con las cookies vs el control de caché que se hace por defecto PHP y que Autentificator ajusta (session_cache_limiter())

Un saludo,
  #3 (permalink)  
Antiguo 06/04/2005, 06:30
 
Fecha de Ingreso: enero-2005
Mensajes: 15
Antigüedad: 12 años, 11 meses
Puntos: 0
gracias por tu respuesta cluster, he seguido haciendo test y demas, con opera va bien, con firefox (linux,mac y windows) va bien, con mozilla va bien, con iexplorer de mac va bien. PERO con iexplorer de windows no va, he aislado el problema y comentando las siguientes lineas del autenticator ya me va en todos:

if ($_SERVER['HTTP_REFERER'] == "")
{
header("Location:aviso2.php?error=1");
}

Ahora bien. que problema puedo tener con las sesiones?? son imprescindibles estas lineas?? que otra solucion puede haber??
gracias. Saludos.

Última edición por josberco; 06/04/2005 a las 09:07
  #4 (permalink)  
Antiguo 06/04/2005, 13:07
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Cita:
Ahora bien. que problema puedo tener con las sesiones?? son imprescindibles estas lineas?? que otra solucion puede haber??
No, no hay problema en eliminar ese código. No afecta para nada la seguridad del script.

La variable "HTTP_REFERER" es un dato que puede ser entregado o no al servidor HTTP (y en consecuencia leido por PHP). Algunas conexiones que pasan por proxys, firewalls o niveles de seguridad altos en navegadores .. pueden bloquear/alterar dicha información ..

La funcionalidad de Autentificator en la que se basa para el uso de HTTP_REFERER es simplemente la de no depender de un formulario de login sólo (y fijo) sino que pueda ser cualquiera de cualquier página, sólo y exclusivamente para devolver a esa página/script los mensajes de error que pudieran ocasionarse en el login. A su vez es una forma rápida de salir del script si se accede directo al mismo (si no hay página referida) .. Pero de igual forma se sigue validando por la existencia de esas variables de sesión si el acceso es correcto.

Un saludo,
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 10:08.