Foros del Web » Programando para Internet » PHP »

Error con codificación PHP y Centos

Estas en el tema de Error con codificación PHP y Centos en el foro de PHP en Foros del Web. Hola Qué tal ? Tengo un problema. Recientemente instalé y configuré apache+php+mysql+ftp en mi servidor Centos 5.8 local. Por cuestiones de cambios en mi sitio ...
  #1 (permalink)  
Antiguo 05/10/2012, 17:33
 
Fecha de Ingreso: agosto-2011
Mensajes: 5
Antigüedad: 8 años, 4 meses
Puntos: 0
Error con codificación PHP y Centos

Hola Qué tal ?

Tengo un problema. Recientemente instalé y configuré apache+php+mysql+ftp en mi servidor Centos 5.8 local. Por cuestiones de cambios en mi sitio decidí hacer un backup y realizar los cambios en mi servidor local para después subirlo a la web. El caso es que tengo varios problemas de codificación tanto en las páginas php como en las conexiones a MySQL. Estoy viendo cómo corregir el problema localmente (apache/php) sin recodificar cada archivo, pues sé que en el servidor web tendrá repercusiones. Si alguien me puede ayudar, estaría agradecido.
  #2 (permalink)  
Antiguo 05/10/2012, 17:49
Avatar de function  
Fecha de Ingreso: abril-2010
Mensajes: 278
Antigüedad: 9 años, 8 meses
Puntos: 13
Respuesta: Error con codificación PHP y Centos

No soy muy entendido con CentOS pero si con Debian. Pero al parecer creeria que es mas de como estan los archivos de configuracion del apache y php en cada servidor

Yo verificaria que apache tengan la misma version y si tienen la misma version, verifica que el php.ini esten igualmente establecidos (misma configuracion), ais mismo miraria los modulos del apache, que esten todo instalados.

Si esta todo igual, no deberia de darte problemas.

PD= Recuerda mirar el locale y los virtualhost

Saludos!!

Muestra el error de codificacion que te aparece para entender mejor
__________________
~# echo Hemos logrado la independencia, pero no la libertad >> SimonBolivar
  #3 (permalink)  
Antiguo 08/10/2012, 13:56
 
Fecha de Ingreso: agosto-2011
Mensajes: 5
Antigüedad: 8 años, 4 meses
Puntos: 0
Respuesta: Error con codificación PHP y Centos

Agradezco tu respuesta!

Mira, me muestra caracteres como

Código:
<span>Qui�nes somos</span>
y cuando empieza una conexión con MySQL solo tira:

Código:
<h1 class="titulo">Productos</h1>
Unknown character set: 'iso-8859-1'
Sé debo configurar algo, pero la verdad no sé por donde moverle. Igual iré buscando... Son bienvenidas todas tus soluciones !

Etiquetas: centos, codificacion, mysql
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 13:25.