Foros del Web » Programando para Internet » PHP »

error con imagecreatefrom...

Estas en el tema de error con imagecreatefrom... en el foro de PHP en Foros del Web. Muy buenas, estoy intentando crearme un script para modificar el tamaño de las imagenes que le pase, y mostrarlas desde la pagina en la que ...
  #1 (permalink)  
Antiguo 07/02/2005, 07:26
 
Fecha de Ingreso: marzo-2004
Mensajes: 71
Antigüedad: 13 años, 8 meses
Puntos: 0
error con imagecreatefrom...

Muy buenas, estoy intentando crearme un script para modificar el tamaño de las imagenes que le pase, y mostrarlas desde la pagina en la que sea llamado,
el codigo es el siguiente:

$imageSize = getimagesize($notImg);
$x=$imageSize[0];
$y=$imageSize[1];


switch($imageSize[2]){
case 1:
imagecreatefromgif($notImg); //echo "la imagen es gif";
break;
case 2:
imagecreatefromjpeg($notImg); //echo "la imagen es jpg";
break;
case 3:
imagecreatefrompng($notImg); //echo "la imagen es png";
break;
}

pero me da el siguiente error en la funcion imagrecreatefrom-- :

Fatal error: Call to undefined function: imagecreatefromjpeg() in c:\inetpub\wwwroot\internews\img\comunicados\resiz e.php on line 20

Nose ha que se puede deber.. si alguien tiene idea me seria de gran ayuda, muchas gracias de antemano¡
Un saludo,
  #2 (permalink)  
Antiguo 07/02/2005, 07:35
 
Fecha de Ingreso: diciembre-2004
Mensajes: 48
Antigüedad: 13 años
Puntos: 0
Librerías

hola barranco acabo de darle un información a sanjo el cual tiene tu mismo problema y que ha preguntado despues de tí fijate alli hay algo de explicación
el problema radica que no tienes instaladas las librerías Gd

leete esto

http://es2.php.net/gd

en las faq tambien hay temas relacionados

suerte
  #3 (permalink)  
Antiguo 07/02/2005, 08:55
 
Fecha de Ingreso: marzo-2004
Mensajes: 71
Antigüedad: 13 años, 8 meses
Puntos: 0
Gracias¡ solo una cosilla mas...

He mirado el link que me pasas, pero veo un mensaje que no me da nada de confianza, dentro de la pagina http://www.boutell.com/gd/ viene la ultima version de estas librerias, pero especifica que no son validas para php...

He leido una documentacion que dice que las librerias gd vienen en la version 4.3.0 de php, igual la mejor solucion es actualizarlo..
Que me aconsejas?¿

Muchas gracias por tu atencion, y un saludo¡
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 19:10.