Foros del Web » Programando para Internet » PHP »

Error con un registro tipo char

Estas en el tema de Error con un registro tipo char en el foro de PHP en Foros del Web. Buenas, inserto registros en una bd. tengo definido un campo como char(2). sorprendentemente, introduzco el registro en la bd, y me pone siempre el valor ...
  #1 (permalink)  
Antiguo 17/12/2003, 11:57
 
Fecha de Ingreso: enero-2002
Mensajes: 1.872
Antigüedad: 15 años, 11 meses
Puntos: 3
Error con un registro tipo char

Buenas, inserto registros en una bd. tengo definido un campo como char(2). sorprendentemente, introduzco el registro en la bd, y me pone siempre el valor go.

a alguien le ha pasado igual?

salu2
  #2 (permalink)  
Antiguo 17/12/2003, 12:19
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Pero ..

** ¿con que lees esos los registros de tu BD? (que administrador: phpMyadmin .. uno tuyo .. otros? ..

** ¿que código usas para insertar esos datos en ese campo? (igual te estás equivocando de campo al componer el INSERT ..)

En fin .. que como no dés más datos .. poco podemos hacer.

Un saludo,
__________________
Por motivos personales ya no puedo estar con Uds. Fue grato haber compartido todos estos años. Igualmente los seguiré leyendo.
  #3 (permalink)  
Antiguo 17/12/2003, 12:28
 
Fecha de Ingreso: enero-2002
Mensajes: 1.872
Antigüedad: 15 años, 11 meses
Puntos: 3
gracias por responder cluster, te explico:

trabajo con el phpmyadmin. el campo esta definido asi

goles1 char(2) NOT NULL default '',


la variable la envio a una pagina donde inserto. tengo 12 registros, y solo me falla este., esta definido igual q los otros. inserto de la siguiente manera:

INSERT INTO resultados(numjornada,fequipo,goles1) VALUES ('$numjornada','$equipo1,'&goles1')

lo mismo para 12 equipos. y todo se inserta correctamente mnenos el campo goles 1, q pone go.

a ver si estos datos te ayudan mas. gracias!
  #4 (permalink)  
Antiguo 17/12/2003, 12:37
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
'&goles1'

Seguro que así es como lo usas en tu código .. o fué un error al ponerlo en el foro? ... $goles1 ..

Has probado hacer un echo $goles1 .. antes de atacar tu insert? o mejor todavía hacer un echo a toda esa sentencia SQL antes de atacar el mysql_query() ... ?

Un saludo,
__________________
Por motivos personales ya no puedo estar con Uds. Fue grato haber compartido todos estos años. Igualmente los seguiré leyendo.
  #5 (permalink)  
Antiguo 17/12/2003, 12:44
 
Fecha de Ingreso: enero-2002
Mensajes: 1.872
Antigüedad: 15 años, 11 meses
Puntos: 3
era un error tipografico. he hecho un echo antes de insertar, y me muestra el numero correctamente. es mas, todos los registros estan puestos de la misma manera, pero curiosamente siempre, en el goles1 me popne go
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 21:06.