Foros del Web » Programando para Internet » PHP »

Error al Conectar con MySql !!URGENTE!!

Estas en el tema de Error al Conectar con MySql !!URGENTE!! en el foro de PHP en Foros del Web. Tengo el siguiente problema al conectar con MySql: Warning: mysql_connect(): Client does not support authentication protocol requested by server; consider upgrading MySQL client in c:\inetpub\wwwroot\icard\includes\dataCon.php ...
  #1 (permalink)  
Antiguo 17/03/2005, 11:26
 
Fecha de Ingreso: noviembre-2003
Ubicación: Guatemala
Mensajes: 72
Antigüedad: 14 años, 1 mes
Puntos: 0
Pregunta Error al Conectar con MySql !!URGENTE!!

Tengo el siguiente problema al conectar con MySql:

Warning: mysql_connect(): Client does not support authentication protocol requested by server; consider upgrading MySQL client in c:\inetpub\wwwroot\icard\includes\dataCon.php on line 8

y este es el codigo de datacon.php:

Código:
<?php 
	//configuro los datos de Acceso al Servidor MySql
	$Host="localhost";
	$User="root"; //"scjuanta_";
	$Pasw="";
	$Datab="asam";  //"scjuanta_innova";
	
	$Dlink=mysql_connect($Host, $User, $Pasw);
	mysql_select_db ($Datab);  
?>
ya desinstale y reinstale Mysql y Php e instale la nueva versin de myodbc 3.51.11 pero me sigue dando el mismo problema...
si alguien puede ayudarme se lo agradeceria bastante pues tengo que entregar un trabajo y hay modo que pase de ahi..

Gracias de Antemano..
  #2 (permalink)  
Antiguo 17/03/2005, 12:01
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
No indicas que versión de Mysql usas .. pero parace que usas una versión 4.1.x con PHP ?.?.? pero usas las funciones mysql_xxxx() para acceder a Mysql.. (eso es el "cliente" que menciona el error).

Bien .. si es ese el caso .. las contraseñas de los usuarios de Mysql las gestiona diferente las versiones 4.0 e inferiores (de Msyql) que la 4.1 y superiores .. Si no quieres complicarte .. debes cambiar los usuarios (sus contraseñas) de Mysql al formato antigüo de contraseñas.

http://www.forosdelweb.com/f18/error-1251-acceder-mysql-por-phpmyadmin-270030/

otra cosa que puedes hacer es usar Mysql 4.0 si realmente no piensas usar las funcionalidades de Mysql 4.1.x o por ejemplo por qué desarrollas "en casa" y luego tu trabajo queda en un servicio de hosting con Mysql 4.0.x o inferior .. (ahí no vale la pena usar una versión "superior" si luego no puedes usarla en tu servidor de "producción").

Un saludo,
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 18:53.