Foros del Web » Programando para Internet » PHP »

Error de directorio al crear Thumbails con GD (ejemplo de ls faq´s)

Estas en el tema de Error de directorio al crear Thumbails con GD (ejemplo de ls faq´s) en el foro de PHP en Foros del Web. hola he pillado el ejemplo de las faq´s para crear thumbails con GD, pero me da siempre erro del directorio, no se como he de ...
  #1 (permalink)  
Antiguo 24/06/2004, 06:11
Avatar de benti  
Fecha de Ingreso: octubre-2001
Ubicación: Benidorm
Mensajes: 413
Antigüedad: 16 años, 1 mes
Puntos: 0
Error de directorio al crear Thumbails con GD (ejemplo de ls faq´s)

hola he pillado el ejemplo de las faq´s para crear thumbails con GD, pero me da siempre erro del directorio, no se como he de poner la ruta, he rpovado de varias formas.
Código PHP:
// Aquí la ruta especificada para buscar la imagen. 
$camino=dirname($imagen)."/";  // asi no va

$camino=dirname($imagen)."/usr/local/psa/home/vhosts/creactiva.net/httpdocs/secciones/users/";  // asi no va

$camino=dirname($imagen)."/secciones/users/";  // asi no va 
Como es ¿?
__________________
Seguro que ahora me sale mejor!
  #2 (permalink)  
Antiguo 24/06/2004, 09:18
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
En tal caso . .sería todo al reves ..

primero tu ruta absoluta de tu servidor (no sé si será la 2º que pusistes .. ) y luego el "dirname($imagen)" ..

Un saludo,
  #3 (permalink)  
Antiguo 24/06/2004, 09:50
Avatar de benti  
Fecha de Ingreso: octubre-2001
Ubicación: Benidorm
Mensajes: 413
Antigüedad: 16 años, 1 mes
Puntos: 0
$camino="/usr/local/psa/home/vhosts/metalmas.com/httpdocs/secciones/users/"dirname($imagen);

Me da parse error
__________________
Seguro que ahora me sale mejor!
  #4 (permalink)  
Antiguo 24/06/2004, 10:07
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Hombre .. te faltó concatenar! ..

Código PHP:
$camino="/usr/local/psa/home/vhosts/metalmas.com/httpdocs/secciones/users/".dirname($imagen); 
Un saludo,
  #5 (permalink)  
Antiguo 24/06/2004, 10:21
Avatar de benti  
Fecha de Ingreso: octubre-2001
Ubicación: Benidorm
Mensajes: 413
Antigüedad: 16 años, 1 mes
Puntos: 0
Tiene mala leche esto ahroa me dice:
No se encuentra la imagen /usr/local/psa/home/vhosts/metalmas.com/httpdocs/secciones/users/.1088090551_1.jpg

fijate en el punto delante de la foto :(
__________________
Seguro que ahora me sale mejor!
  #6 (permalink)  
Antiguo 08/05/2005, 13:45
 
Fecha de Ingreso: abril-2004
Ubicación: Concepcion
Mensajes: 72
Antigüedad: 13 años, 7 meses
Puntos: 0
A mi me pasa igual en este codigo, y ojo porque lo saque exactamente igual como sale en el Faq, es decir que el faq esta malo??. Cuando llamo a la funcion pa mostrar me aparece esto:
No se encuentra la imagen /var/www/thumbails/.cumple_jorgue.jpeg . El que realizo el faq podria aclarar esto???
  #7 (permalink)  
Antiguo 09/05/2005, 09:20
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Cita:
Iniciado por sombra_cl
A mi me pasa igual en este codigo, y ojo porque lo saque exactamente igual como sale en el Faq, es decir que el faq esta malo??. Cuando llamo a la funcion pa mostrar me aparece esto:
No se encuentra la imagen /var/www/thumbails/.cumple_jorgue.jpeg . El que realizo el faq podria aclarar esto???
La FAQ tiene autor .. si lo desean le envian un mensaje privado para que aclare el asunto.

Un saludo,
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 17:59.