Foros del Web » Programando para Internet » PHP »

Error al enviar un formulario

Estas en el tema de Error al enviar un formulario en el foro de PHP en Foros del Web. Buenos días.... yo hice un formulario en html donde primero se debe elegir al destinatario del mensaje, luego rellenar los demás campos...bueno.... la acción del ...
  #1 (permalink)  
Antiguo 23/04/2006, 07:50
 
Fecha de Ingreso: septiembre-2005
Mensajes: 36
Antigüedad: 12 años, 2 meses
Puntos: 0
Exclamación Error al enviar un formulario

Buenos días.... yo hice un formulario en html donde primero se debe elegir al destinatario del mensaje, luego rellenar los demás campos...bueno.... la acción del formulario al presionar enviar es ir al archivo contacto.php, donde se fija a quien se debe enviar....
El código es el siguiente:

<?php
{
$mens = $mensaje." -Enviado desde oiRaD´S WeB | CoNTaCTo";

// oiRaD

if($serv=="admin"){

$ncel = "[email protected]";

mail($ncel, $de, $mens,"FROM: CONTACTO <[email protected]>\n");

echo "Se ha enviado el mensaje al WeBMaSTeR" !"."<br>";

die();
}
//oiRaD
// ************************************************** ******************************
// MaNu

if($serv=="col1"){

$ncel = "[email protected]";

mail($ncel, $de, $mens,"FROM: CONTACTO <[email protected]>\n");

echo "Se ha enviado el mensaje a MaNu " !"."<br>";

die();

}
// MaNU
// ************************************************** ******************************
// MaRCoS

if($serv=="col2"){

$ncel = "[email protected]";

mail($ncel, $de, $mens,"FROM: CONTACTO <[email protected]>\n");

echo "Se ha enviado el mensaje a MaRCoS " !"."<br>";

die();

}
// MaRCoS
// ************************************************** ******************************
// KiDMaTRiX

if($serv=="col3"){

$ncel = "[email protected]";

mail($ncel, $de, $mens,"FROM: CONTACTO <[email protected]>\n");

echo "Se ha enviado el mensaje a KiDMaTRiX " !"."<br>";

die();

}
// KiDMaTRiX


}
echo "se produjo un error al envio";

?>

Cuando presiono "enviar" me tira el siguiente error:

"Parse error: parse error, unexpected '!', expecting ',' or ';' in /home/vl000018/public_html/contacto.php on line 14"

Me pueden ayudar? Gracias

By oiRaD
  #2 (permalink)  
Antiguo 23/04/2006, 08:33
Avatar de jcxnet  
Fecha de Ingreso: octubre-2005
Ubicación: Perú
Mensajes: 784
Antigüedad: 12 años, 2 meses
Puntos: 56
Al parecer las sentencias de este tipo son el error:
echo "Se ha enviado el mensaje al WeBMaSTeR" !"."<br>";
podrías indicarlas así:
echo "Se ha enviado el mensaje al WeBMaSTeR !<br>";
__________________
►I'm a devil on the run ♂
Jcxnet.com
*Keep It Simple **
  #3 (permalink)  
Antiguo 23/04/2006, 09:11
 
Fecha de Ingreso: septiembre-2005
Mensajes: 36
Antigüedad: 12 años, 2 meses
Puntos: 0
Muchisimas gracias funciona a la perfección..... te lo agradezco

by oiRaD
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 07:43.