Foros del Web » Programando para Internet » PHP »

Error en formato al enviar mail

Estas en el tema de Error en formato al enviar mail en el foro de PHP en Foros del Web. Hola tengo un pequeño problema al enviar un mail resulta que el envio es exitoso, el mail llega incluso antes de enviarlo reviso los links ...
  #1 (permalink)  
Antiguo 27/02/2004, 14:10
 
Fecha de Ingreso: diciembre-2003
Ubicación: Quillota
Mensajes: 196
Antigüedad: 14 años
Puntos: 0
Error en formato al enviar mail

Hola tengo un pequeño problema al enviar un mail
resulta que el envio es exitoso, el mail llega incluso antes de enviarlo reviso los links qu ese envian y abren todas (envio los titulos de noticias y quiero que cuando lean el mail puedan abrir la noticia qwue se encuentra en la pagina inchando en el titulo) pero al revisar el mail resulta que se cambian las direcciones de los titulos, no a erroneas pero se agregan otras
el coodigo es este

Código PHP:

$agreg
=$agregado[$i];
$cuerpo .= '<font size="4"><a href="http://mi.pagina.cl/archivo_noticias.php?codigo_not='$agreg.'" target="_blank">'
.$noti_titulo.'</a><br><font  size="2">'
.$noti_epigrafe.'</font><br><br>';

/*luego hago un echo a cuerpo y muestra bien los links incluso 
abre bien pero cuando reviso en el mail las direcciones quedan 
diferentes por ejemplo asi*/ 
http://mi.pagina.cl/"http://mi.pagina.cl/archivo_noticias.php?codigo_not=46\"

//y desde yahoo se ve asi el link cuando lo abro

http://mail.yahoo.com/config/login?/"http://mi.pagina.cl/archivo_noticias.php?codigo_not=46\"
//ese link aparece si desde el mail (por ejemplo yahoo y hotmail) apreto en el link

cual es el error que he estado toda la tarde y no encuentro nada malo
  #2 (permalink)  
Antiguo 27/02/2004, 15:06
Avatar de claudiovega  
Fecha de Ingreso: octubre-2003
Ubicación: Puerto Montt
Mensajes: 3.667
Antigüedad: 14 años, 1 mes
Puntos: 11
a ver, prueba asi:

$agreg=$agregado[$i];
$cuerpo .= "<font size='4'><a href='http://mi.pagina.cl/archivo_noticias.php?codigo_not=$agreg' target='_blank'>"
.$noti_titulo."</a><br><font size='2'>"
.$noti_epigrafe."</font><br><br>";

/*luego hago un echo a cuerpo y muestra bien los links incluso
abre bien pero cuando reviso en el mail las direcciones quedan
diferentes por ejemplo asi*/
__________________
Dedicado a proyectos web, actualmente desarrollando un sistema de diseño de flyers online muy fácil de usar.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 03:34.