Foros del Web » Programando para Internet » PHP »

error al instalar php4

Estas en el tema de error al instalar php4 en el foro de PHP en Foros del Web. Hola pues yo ya antes habia usado php4 y no habia tenido ningun problema al instalarlo manualmente con apache. Lo que agrego en el archivo ...
  #1 (permalink)  
Antiguo 05/03/2005, 13:33
 
Fecha de Ingreso: marzo-2002
Mensajes: 449
Antigüedad: 15 años, 8 meses
Puntos: 0
error al instalar php4

Hola pues yo ya antes habia usado php4 y no habia tenido ningun problema al instalarlo manualmente con apache. Lo que agrego en el archivo httpd.conf es como dice en el manual:

AddType application/x-httpd-php .php
LoadModule php4_module "C:/php-4.3.10-Win32/sapi/php4apache.dll"
SetEnv PHPRC "C:/php-5.0.3-Win32"

pero cuando corro el apache me da el siguiente error:

Syntax error on line 991 of c:/archivos de programa/apache group/apache/conf/htt
pd.conf:
Cannot load c:/php-4.3.10-win32/sapi/php4apache.dll into server: (126) No se pue
de encontrar el m¾dulo especificado:

Bueno el error es logico no se ha encontrado la libreria.
Pero resulta que si instalo php5 con:

AddType application/x-httpd-php .php
LoadModule php5_module "C:/php-5.0.3-Win32/php5apache.dll"
SetEnv PHPRC "C:/php-5.0.3-Win32"

no tengo ningun problema.

Lo anterior lo he probado primero con apache 1.3, pero tambien con apache 2 (con sus respectivos cambios de sintaxis en el archivo httpd.conf ) y los resultados son los mismos.

Alguna idea de porque no se puede encontrar php4 o porque reusa apache a cargarlo. Error con el path de php4 no es.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 23:13.