Foros del Web » Programando para Internet » PHP »

Error en pagina wml con php

Estas en el tema de Error en pagina wml con php en el foro de PHP en Foros del Web. HOLA estoy desesperado, hice una pagina wml con codigo php, y la eh puesto en el servidor, la probe en un emulador que viene en ...
  #1 (permalink)  
Antiguo 08/05/2004, 20:32
Avatar de christianMen  
Fecha de Ingreso: abril-2004
Ubicación: Tijuana
Mensajes: 37
Antigüedad: 13 años, 8 meses
Puntos: 1
Error en pagina wml con php

HOLA estoy desesperado, hice una pagina wml con codigo php, y la eh puesto en el servidor, la probe en un emulador que viene en www.wmlclub.com......... Mi peticion es: haber si me pueden ayudar a que se vea bien la pagina, en que estoy mal en el codigo o si es del servidor ?, porque se ve la la pagina pero la parte que esta hecha con php no lo hace, muestra el codigo de php, me explico ?.....aqui les mando el codigo:

<?php
header("Content-type: text/vnd.wap.wml");
echo "";
echo " . " \"http://www.wapforum.org/DTD/wml_1.1.xml\">";
?>

<wml>
<card id="card1" title="Instituto Tecnológico de Colima">
<p align="center">
<do type="text" label="Entrar">
<go method="get" href="menu.wml#card1" />
</do>
<?php
print "<br/> Instituto Tecnológico de Colima<br/><br/>";

//recojo datos <<este es el codigo que se ve en pantalla >>
$date_mes = date("n");
$date_dia = date("w");
$dia = date("j");
$ano = date("Y");
$hora = date("H");
$min = date("i");

$meses = array(1 => "Enero","Febrero","Marzo","Abril","Mayo","Junio"," Julio","Agosto","Septiembre","Octubre","Nobiembre" ,"Diciembre");
$dias = array("Domingo","Lunes","Martes","Miercoles","Juev es","Viernes","Sabado");

//el formato es: dia_letra, dia_numero.mes año
$fecha = "$dias[$date_dia], $dia.$meses[$date_mes] $ano";
print "<p align='center'> $fecha <br/>";

print "<br/><br/>¡Bienvenido al Sitio!";
?>
</p>
</card>
</wml>

-----------------------------------------------------------
El servidor esta con IIS ya lo configure para que se vean paginas en hechas en php y wml, y ya seben las dos, pero como les digo el codigo que esta hecho en php no me lo ejecuta.... hay que moverle algo alservidor ?..... o es del codigo ?
__________________
°-° Christian °-°
  #2 (permalink)  
Antiguo 09/05/2004, 06:09
Ex Colaborador
 
Fecha de Ingreso: junio-2002
Mensajes: 9.091
Antigüedad: 15 años, 6 meses
Puntos: 16
Hola,

Supongo que llamaras al fichero loquesea.php para que lo ejecute como un PHP.

Saludos.
__________________
Josemi

Aprendiz de mucho, maestro de poco.
  #3 (permalink)  
Antiguo 09/05/2004, 12:30
Avatar de christianMen  
Fecha de Ingreso: abril-2004
Ubicación: Tijuana
Mensajes: 37
Antigüedad: 13 años, 8 meses
Puntos: 1
hola !!

no entendi lo que me quisite decir, pero para mandarlo llamar lo estoy haciendo asi: ...../wml/inicio.wml porque esta guardado como wml me explico ? o que es lo que quereís decir ...
__________________
°-° Christian °-°
  #4 (permalink)  
Antiguo 09/05/2004, 13:08
Ex Colaborador
 
Fecha de Ingreso: junio-2002
Mensajes: 9.091
Antigüedad: 15 años, 6 meses
Puntos: 16
Que si tienes solo configurado el IIS para que tome los .php como scripts PHP, debes llamar al fichero inicio.php para que ejecute el codigo PHP.

Saludos.
__________________
Josemi

Aprendiz de mucho, maestro de poco.
  #5 (permalink)  
Antiguo 09/05/2004, 14:13
Avatar de christianMen  
Fecha de Ingreso: abril-2004
Ubicación: Tijuana
Mensajes: 37
Antigüedad: 13 años, 8 meses
Puntos: 1
configurar iis

Segun yo si, esta configurado para que hacepte asp, php y wml, pero en donde pones las paginas como determinadas creo que no eh puesto la de inicio.wml deja checo, pero hay otra cosa que se tenga que hacer ?
__________________
°-° Christian °-°
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 02:45.