Foros del Web » Programando para Internet » PHP »

Error por actualización de AppServ

Estas en el tema de Error por actualización de AppServ en el foro de PHP en Foros del Web. Actualicé la versión de AppServ a la 2.4.5 (Apache 1.3.34, PHP 4.4.1, MySQL 5.0.16 y phpMyAdmin-2.5.7-pl1) en mi pc con Win xp, ya que necesito ...
  #1 (permalink)  
Antiguo 16/04/2006, 17:05
 
Fecha de Ingreso: enero-2003
Ubicación: La Florida, Stgo
Mensajes: 40
Antigüedad: 14 años, 10 meses
Puntos: 0
Error por actualización de AppServ

Actualicé la versión de AppServ a la 2.4.5 (Apache 1.3.34, PHP 4.4.1, MySQL 5.0.16 y phpMyAdmin-2.5.7-pl1) en mi pc con Win xp, ya que necesito trabajar con MySQL 5, y desde entonces tengo el siguiente error en el archivo de conexión php:

Código PHP:
Warningmysql_connect(): Client does not support authentication protocol requested by serverconsider upgrading MySQL client

Fatal error
Client does not support authentication protocol requested by serverconsider upgrading MySQL client 
Y en el archivo de conexión uso la función mysql_connect($hostname, $username, $password)


Alguna idea?

salu2
__________________
:neurotico:neurotico:neurotico:neurotico:neurotico :neurotico:neurotico:neurotico:neurotico:neurotico :neurotico:neurotico:neurotico:neurotico:neurotico
  #2 (permalink)  
Antiguo 16/04/2006, 20:42
Avatar de emiliodeg  
Fecha de Ingreso: septiembre-2005
Ubicación: Córdoba
Mensajes: 1.830
Antigüedad: 12 años, 3 meses
Puntos: 54
en esa vrsion de appserv la bd tiene por defecto usuario "root" pero sin contraseña
por ende deberias usar
$conexion=mysql_connect("localhost","root","");
  #3 (permalink)  
Antiguo 16/04/2006, 22:04
 
Fecha de Ingreso: enero-2003
Ubicación: La Florida, Stgo
Mensajes: 40
Antigüedad: 14 años, 10 meses
Puntos: 0
Y entonces como creo mis usuarios?
__________________
:neurotico:neurotico:neurotico:neurotico:neurotico :neurotico:neurotico:neurotico:neurotico:neurotico :neurotico:neurotico:neurotico:neurotico:neurotico
  #4 (permalink)  
Antiguo 16/04/2006, 22:09
 
Fecha de Ingreso: abril-2003
Mensajes: 201
Antigüedad: 14 años, 8 meses
Puntos: 0
te recomiendo este manual :
http://www.maestrosdelweb.com/editorial/phpmysqlap/
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 23:48.