Foros del Web » Programando para Internet » PHP »

Error al usar mail(). Alguien me puede ayudar?

Estas en el tema de Error al usar mail(). Alguien me puede ayudar? en el foro de PHP en Foros del Web. Hola. Estoy de lleno con el libro de Luke Welling y Laura Thomson "Desarrollo web con PHP y MySQL" haciendo ejercicios y pruebas, pero me ...
  #1 (permalink)  
Antiguo 27/08/2005, 12:05
 
Fecha de Ingreso: mayo-2003
Mensajes: 527
Antigüedad: 14 años, 6 meses
Puntos: 3
Error al usar mail(). Alguien me puede ayudar?

Hola. Estoy de lleno con el libro de Luke Welling y Laura Thomson "Desarrollo web con PHP y MySQL" haciendo ejercicios y pruebas, pero me he tropezado con un problema que no consigo solucionar. Es a la hora de usar un sencillo script en PHP de procesamiento de un envío de correo. Aquí está el script:

Código:
<?php 
// Crear nombres de las variables obtenidas del formulario:
$name = $_POST['name'];
$email = $_POST['email'];
$feedback = $_POST['feedback'];

$destino = '[email protected]'; //mi email personal
$subject = 'Feedback from website';
$mailcontent = 'Customer name: '.$name."\n".
				'Customer email: '.$email."\n".
				"Customer comments: \n".$feedback."\n";
$remitente = 'From: [email protected]';

mail($destino, $subject, $mailcontent, $remitente);
?>
He probado instalando los servidores de correo Argosoft y Liteserve, y aparentemente me funcionan. He conseguido que no me den error, pero no llego a recibir ningún e-mail al destino especificado. Tengo el firewall Zone Alarm, pero he probado a ponerlo en nivel medio e incluso lo he desactivado momentáneamente y tampoco va. Ambos servidores de correo me funcionan bien. Sus respectivas consolas muestran el mensaje "SMTP listening on port 25", el cual tengo configurado en "php.ini"

El formulario HTML está bien, y las variables de formulario se corresponden perfectamente. Uso un servidor Apache en Windows XP.

Alguien sabría decirme qué puede estar fallando?

Última edición por Tigervlc; 27/08/2005 a las 12:22
  #2 (permalink)  
Antiguo 27/08/2005, 13:42
 
Fecha de Ingreso: agosto-2005
Ubicación: Valencia
Mensajes: 76
Antigüedad: 12 años, 3 meses
Puntos: 1
Primeramente, la dirección que envía el correo ([email protected]) ha de ser válida, o sea de un dominio en uso y una dirección de correo operativa.

En el php.ini, si es windows, deberás especificar un servidor smtp válido, que esté asociado a la dirección de correo que envía:

[email protected] //Correo que envia
mailhost.terra.es //Servidor smtp válido

Y por suspuesto la direccion que envia y la que recibe nunca ha de ser la misma.

De todas formas hay un servidor SMTP especial, que te permite enviar correos desde el localhost sin ningún problema y casí sin configuración. Es de pago y se llama QKSMTP Server.
__________________
Quien a buen árbol se arrima, buena sombra le cobija. :aplauso:

http://dbtrucos.com
  #3 (permalink)  
Antiguo 02/09/2005, 20:27
 
Fecha de Ingreso: mayo-2003
Mensajes: 527
Antigüedad: 14 años, 6 meses
Puntos: 3
Gracias por la respuesta. Probaré lo que dices.

Un saludo!
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 16:52.