Foros del Web » Programando para Internet » PHP »

estoy Decepcionado

Estas en el tema de estoy Decepcionado en el foro de PHP en Foros del Web. Gente acabo de postear esto mismo y nadie me da bolilla, cambie el titulo haber si entran y lo leen al menos, este foro me ...
  #1 (permalink)  
Antiguo 12/02/2005, 20:24
 
Fecha de Ingreso: febrero-2005
Mensajes: 7
Antigüedad: 12 años, 10 meses
Puntos: 0
estoy Decepcionado

Gente acabo de postear esto mismo y nadie me da bolilla, cambie el titulo haber si entran y lo leen al menos, este foro me lo recomendo un amigo y me dijo que te contestan rapido sera asi????

bueno lo mio es rapido tengo un formulario en el cual cargo unos datos, luego creo unas variables de SESSION de la siguiente manera:

Código PHP:
if ($_POST['enviar'] != "") { 
    for (
$i=0$i count ($_POST['foto']); $i++){ 
    
$id_foto $_POST['foto'][$i]; 

    
$_SESSION['1015'][$id_foto] = $_POST['cant1015'][$i]; 
    
$_SESSION['1318'][$id_foto] = $_POST['cant1318'][$i]; 
    
$_SESSION['1521'][$id_foto] = $_POST['cant1521'][$i]; 
    
$_SESSION['2025b'][$id_foto] = $_POST['cant2025b'][$i]; 
    
$_SESSION['2025m'][$id_foto] = $_POST['cant2025m'][$i]; 
     
    } 
             } 
El problema es que cuando paso a otra pagina estas variables de SESSION se me borran ose se me quedan sin los datos cargados.
Las estoy creando mal.
Bueno espero opiniones
PD: esta session_start() en el inicio de la pagina
  #2 (permalink)  
Antiguo 12/02/2005, 21:18
Avatar de Nefertiter  
Fecha de Ingreso: enero-2003
Ubicación: Rosario
Mensajes: 1.316
Antigüedad: 14 años, 11 meses
Puntos: 8
mira para mi si se te pierden los datos para mi el problema debe estar en q te falta un session_start() em alguna de las paginas, q te digo es conveniente este en TODAS y te sugiero pruebes ver si tomaron valor las variables de session despues de tu script agregando


Código PHP:
 print_r$_SESSION); 
  #3 (permalink)  
Antiguo 12/02/2005, 21:46
Avatar de jpinedo
Colaborador
 
Fecha de Ingreso: septiembre-2003
Ubicación: Lima, Perú
Mensajes: 3.120
Antigüedad: 14 años, 2 meses
Puntos: 41
Además de eso... haz una búsqueda en este foro y encontrarás varios posts donde se toca el tema de sesiones que no funcionan.
Muchas veces tiene que ver con la configuración de PHP.
¿Estás en un servidor local?¿qué versión de PHP utilizas?
Sobre el estado de algunas directivas...
¿Pasas el SID por cookies?¿Tu navegador las acepta?
¿Pasas el SID por url?¿Estás agregándolo manualmente donde es necesario?

Saludos
  #4 (permalink)  
Antiguo 13/02/2005, 12:10
 
Fecha de Ingreso: febrero-2005
Mensajes: 396
Antigüedad: 12 años, 10 meses
Puntos: 1
Pues si crees que por poner un título así voy a responder algo...
  #5 (permalink)  
Antiguo 13/02/2005, 19:09
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
En otro mensaje abierto por ti mismo con la misma pregunta tu mismo te diste respuesta:

http://www.forosdelweb.com/f18/que-pasa-con-php-sessiones-funciona-270393/

Ten presente que esto son foros que la gente participa por amor al arte .. sin màs, asì que no "exijas" una respuesta ni menos rápida. Esto de obtener una respuesta rápida va en función de los datos que tu aportes cuantos màs, mejor y de preguntas (temas) descriptivos y de la predisposiciòn de la gente en ese momento.

Si notas que no obtienes respuesta a un mensaje, insiste en tu mismo mensaje aportando màs datos si corresponde, pero no abriendo temas nuevos iguales.

Un saludo,
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 09:00.