Foros del Web » Programando para Internet » PHP »

Extraño problema. Es sencillo pero ...

Estas en el tema de Extraño problema. Es sencillo pero ... en el foro de PHP en Foros del Web. estoy metiendo por url una variable. la obtengo y luego, para que salga siempre impar, lo que hago es lo siguiente: <?php $numero = $HTTP_GET_VARS["NumPost"]; ...
  #1 (permalink)  
Antiguo 04/06/2006, 10:57
Avatar de darkgaze  
Fecha de Ingreso: febrero-2006
Ubicación: Madrid, España
Mensajes: 462
Antigüedad: 11 años, 9 meses
Puntos: 2
Extraño problema. Es sencillo pero ...

estoy metiendo por url una variable. la obtengo y luego, para que salga siempre impar, lo que hago es lo siguiente:

<?php
$numero = $HTTP_GET_VARS["NumPost"];
if ((is_int($numero))&&(($numero % 2) == 0)) $numero--;
?>

Como lo que puede entrar son palabras o enteros, he puesto una cosa que comprueba.

Pues no me lo hace, meta el numero que meta.

Habrá algo mal de sintaxis? no entiendo nada, chicos. Me podéis echar un cable?.

Luego utilizo la variable numero en otras cosas, y parece que siempre se queda con el que entra, y no lo modifica. U_U
  #2 (permalink)  
Antiguo 04/06/2006, 11:15
Avatar de darkgaze  
Fecha de Ingreso: febrero-2006
Ubicación: Madrid, España
Mensajes: 462
Antigüedad: 11 años, 9 meses
Puntos: 2
ya lo tengo. había que usar is_numeric()


que porra. Gracias de todas formas, chicos.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 07:49.