Foros del Web » Programando para Internet » PHP »

Fallo con etiquetas html en foro

Estas en el tema de Fallo con etiquetas html en foro en el foro de PHP en Foros del Web. Hola! Bueno, mi fallo es que tengo un foro creado, pero... si una persona comenta en algún sitio: Código HTML: <meta HTTP-EQUIV="REFRESH" content= "0; url=http://google.es" ...
  #1 (permalink)  
Antiguo 24/03/2012, 13:55
Avatar de Soir  
Fecha de Ingreso: marzo-2011
Mensajes: 40
Antigüedad: 8 años, 9 meses
Puntos: 1
Fallo con etiquetas html en foro

Hola!

Bueno, mi fallo es que tengo un foro creado, pero... si una persona comenta en algún sitio:

Código HTML:
<meta HTTP-EQUIV="REFRESH" content="0; url=http://google.es"> 
El foro redirecciona a Google... es un problema bastante importante, me gustaría saber si se puede solucionar.

Antes utilizaba la etiqueta nl2br, la he probado y hago el reemplazo por str_replace, pero el problema es que sigue redireccionando, así que probé quitando la nl2br y sigue pasado....

¿Solución? :S
  #2 (permalink)  
Antiguo 25/03/2012, 12:44
 
Fecha de Ingreso: octubre-2011
Mensajes: 230
Antigüedad: 8 años, 1 mes
Puntos: 75
Respuesta: Fallo con etiquetas html en foro

Cita:
Iniciado por Soir Ver Mensaje
Hola!

Bueno, mi fallo es que tengo un foro creado, pero... si una persona comenta en algún sitio:

Código HTML:
<meta HTTP-EQUIV="REFRESH" content="0; url=http://google.es"> 
El foro redirecciona a Google... es un problema bastante importante, me gustaría saber si se puede solucionar.

Antes utilizaba la etiqueta nl2br, la he probado y hago el reemplazo por str_replace, pero el problema es que sigue redireccionando, así que probé quitando la nl2br y sigue pasado....

¿Solución? :S
¿A dónde quieres que redireccione?

Saludos.
  #3 (permalink)  
Antiguo 26/03/2012, 08:33
Avatar de Soir  
Fecha de Ingreso: marzo-2011
Mensajes: 40
Antigüedad: 8 años, 9 meses
Puntos: 1
Respuesta: Fallo con etiquetas html en foro

A ningún lado, el tema es que la gente se aprovecha del foro que he creado poniendo ese tipo de etiquetas y no se como evitarlo.
  #4 (permalink)  
Antiguo 26/03/2012, 08:37
 
Fecha de Ingreso: octubre-2011
Mensajes: 230
Antigüedad: 8 años, 1 mes
Puntos: 75
Respuesta: Fallo con etiquetas html en foro

Cita:
Iniciado por Soir Ver Mensaje
A ningún lado, el tema es que la gente se aprovecha del foro que he creado poniendo ese tipo de etiquetas y no se como evitarlo.
Pues no pongas esa etiqueta meta. Porque es imposible que te hagan inyecciones de código HTML, o que es lo que ocurre.

Saludos.

Etiquetas: etiquetas, fallo, foro, html
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 20:55.