Foros del Web » Programando para Internet » PHP »

Fatal error: !!

Estas en el tema de Fatal error: !! en el foro de PHP en Foros del Web. Hola amigos! mi problema es el siguiente: Fatal error: Call to undefined function: pg_pconnect() esto sucede cuando trato de conectarme con php a una base ...
  #1 (permalink)  
Antiguo 28/05/2003, 16:09
 
Fecha de Ingreso: diciembre-2002
Ubicación: Villa Alemana
Mensajes: 103
Antigüedad: 15 años
Puntos: 0
Fatal error: !!

Hola amigos!
mi problema es el siguiente:

Fatal error: Call to undefined function: pg_pconnect()

esto sucede cuando trato de conectarme con php a una base de datos Postgresql!

hasta hace unos días me funcionaba, pero quizas al actualizar Php de 4.1 a 4.3 tuvo algun efecto?
aqui pongo el código:


Código PHP:
$conexion pg_connect("host=200.1.25.108 port=5432 dbname=letras")or die("¡No se ha podido establecer la conexión con el servidor local!"); 
porfavor ayuda!!
gracias
  #2 (permalink)  
Antiguo 28/05/2003, 16:21
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Pues el "defecto" fué que no instalastes (compilastes PHP) con opción de PostgreSQL:

Recompila PHP con opción:

--with-pgsql[=DIR]

(donde dir es donde tengas tu PostgreSQL .. )

http://www.php.net/manual/en/ref.pgsql.php

Un saludo,
__________________
Por motivos personales ya no puedo estar con Uds. Fue grato haber compartido todos estos años. Igualmente los seguiré leyendo.
  #3 (permalink)  
Antiguo 29/05/2003, 16:10
 
Fecha de Ingreso: diciembre-2002
Ubicación: Villa Alemana
Mensajes: 103
Antigüedad: 15 años
Puntos: 0
gracias !!

muchas gracias, la verdad es q estoy conversando el asunto con el administrador, espero con tu ayuda lo solucione !!

saludos

pucha!!
no resulta y sigue tirando el mismo error, he buscado informacion al respecto y todo apunta a lo mismo.
Quizas sea otro el error y puede q tenga q ver con PostgreSql?
en phpinfo(), tendria que salir informacion de Postgresql?

Configure Command './configure' '--with-mysql' '--with-apxs'

en esta linea tendría q aparecer --with-pgsql=/usr/local/pgsql ?

Ayuda porfavor!!!

pucha!!
no resulta y sigue tirando el mismo error, he buscado informacion al respecto y todo apunta a lo mismo.
Quizas sea otro el error y puede q tenga q ver con PostgreSql?
en phpinfo(), tendria que salir informacion de Postgresql?

Configure Command './configure' '--with-mysql' '--with-apxs'

en esta linea tendría q aparecer --with-pgsql=/usr/local/pgsql ?

Ayuda porfavor!!!

Última edición por kryna; 29/05/2003 a las 16:00
  #4 (permalink)  
Antiguo 29/05/2003, 16:41
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Con --with .. añades el soporte de las extensiones que requieras .. una de ellas es la que necesitas:

--with-pgsql=/usr/local/pgsql

Ademas no es sustituir la de msyql por la de pg .. puedes usar ambos ...

En tu phpinfo() debe salir dicho soporte para PostgreSQL .. hasta que no lo veas no habras compilado bien PHP.

Un saludo,
__________________
Por motivos personales ya no puedo estar con Uds. Fue grato haber compartido todos estos años. Igualmente los seguiré leyendo.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 20:49.