Foros del Web » Programando para Internet » PHP »

file_exists no me funciona

Estas en el tema de file_exists no me funciona en el foro de PHP en Foros del Web. Hola Uso el file_exists en mi pc y todo bien pero al subirlo al server ya no funciona este es el codigo que uso: Código ...
  #1 (permalink)  
Antiguo 27/12/2002, 10:58
Avatar de rickoe
Colaborador
 
Fecha de Ingreso: abril-2001
Mensajes: 353
Antigüedad: 16 años, 7 meses
Puntos: 2
file_exists no me funciona

Hola

Uso el file_exists en mi pc y todo bien

pero al subirlo al server ya no funciona

este es el codigo que uso:


Código PHP:
    while ($m <= 12) {
           
$filename "mp/MP";
        
$filename .= $ano;
        
$filename .= "-";
        
$filename .= $m;
        
$filename .= ".jpg";
        
$si file_exists($filename);
        If (
$si 0) {
            echo 
"<td><A href='ver.php?a=$ano&m=$m' title='Click para ver mas grande'><img src='mp/thumb/t_MP$ano-$m.jpg' width='37' height='50'></A></td>\n";
            
$conmes++;
            
$contot++;
        }
        else {
            echo 
"<td><A href='falta.php' title='¿Quien tiene esta? Click aquí si tu la tienes.'><img src='img/yte.gif' width='34' height='50' border='0'></A></td>\n";
        }
    
$m++;
    }
echo 
"<td class='micmp2'>$conmes</td>";
$conmes 0;
$ano++;
$m 1;

Alguien por ahí tiene idea de que este fallando?

Mil gracias de antemano

Saludos

Rickoe
  #2 (permalink)  
Antiguo 27/12/2002, 12:19
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Tendrias que decir que Sistema operativo usa tu servidor "casa" y el de internet .. (sobre todo indicar si es gratuito o de pago) .. Mirar como trabaja tu servidor de internet (safe mode tal vez? .. está instalado como CGI? .. tiene alguna funcion restringida? )

Las versiones tambien influyen .. no todas las funciones estan disponibles desde todas las versiones (informate en php.net manual desde cuando está disponible ..)

Como veras .. PHP junto con X servidor se puede comportar de forma muyyyy diferencte segun sea su configuracion y versión ...

Haz un phpinfo() a tu servidor de "casa" y otro al de internet... busca diferencias ...

Un saludo,
  #3 (permalink)  
Antiguo 27/12/2002, 17:34
Avatar de rickoe
Colaborador
 
Fecha de Ingreso: abril-2001
Mensajes: 353
Antigüedad: 16 años, 7 meses
Puntos: 2
ok

ok, voy a checar eso que me comentas, te adelanto que mi hosting no es gratuito, es más, es el mismo que el de estos foros

pero ok, que pasa si el file_exists aun asi no funciona?

existe algún otro metodo?

Saludos

Rickoe
  #4 (permalink)  
Antiguo 27/12/2002, 17:58
Avatar de rickoe
Colaborador
 
Fecha de Ingreso: abril-2001
Mensajes: 353
Antigüedad: 16 años, 7 meses
Puntos: 2
Ya

Ya logre que funcionara, solo era cuestion de poner la ruta completa de la ubicacion del archivo

Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 19:57.