Foros del Web » Programando para Internet » PHP »

Formulario bien en mozilla, mal en explorer

Estas en el tema de Formulario bien en mozilla, mal en explorer en el foro de PHP en Foros del Web. Hola a todos. TEngo un formulario metido en un echo de php. El codigo del form y del boton es el siguiente: <form name=\"formulario\" id=\"formulario\" ...
  #1 (permalink)  
Antiguo 27/06/2005, 12:08
 
Fecha de Ingreso: octubre-2003
Mensajes: 280
Antigüedad: 14 años, 1 mes
Puntos: 1
Formulario bien en mozilla, mal en explorer

Hola a todos. TEngo un formulario metido en un echo de php. El codigo del form y del boton es el siguiente:

<form name=\"formulario\" id=\"formulario\" action=\"actualizar.php?accion=guardar\" method=\"POST\" enctype=multipart/form-data>

---

<input type=\"image\" src=\"../Images/ok.jpg\" name=\"Actualizar\" value=\"Actualizar\">

El problema es que me funciona perfectamente en el mozilla, y no en el explorer, en donde no hace nada. ¿Porqué puede ser?

Un saludo.
  #2 (permalink)  
Antiguo 27/06/2005, 12:13
Avatar de lado2mx
Colaborador
 
Fecha de Ingreso: agosto-2001
Ubicación: Veracruz
Mensajes: 3.720
Antigüedad: 16 años, 4 meses
Puntos: 9
En teoría, si en Mozilla funciona y en explorer no, tienes que checar si el explorer está bien instalado y configurado.

Checa tambien como resulta el código fuente de tu página, al sacar el resultado en Mozilla y en Explorer
  #3 (permalink)  
Antiguo 28/06/2005, 02:26
Avatar de jam1138
/** @package Moderador */
 
Fecha de Ingreso: julio-2004
Ubicación: sèveR led onieR lE
Mensajes: 9.368
Antigüedad: 13 años, 4 meses
Puntos: 101
Una vez entregada la página no tiene nada que ver con PHP... problemas con Navegadores son cuestiones del propio HTML, JavaScript y demás lenguajes implicados... son estos lo que te interpreta el navegador no PHP... como aclaración.

Ahora, tu error es que quieres pasar variables por el action (URL)... eso en principio no es correcto, menos usando POST puede resultar un poco contradictorio ¿no? . La solución es poner esos valores que tienes en la URL como elementos (ocultos) del mismo formulario... osease, convertir esto:
Código HTML:
<form name="formulario" action="actualizar.php?accion=guardar" method="POST"> 
a esto:
Código HTML:
<form name="formulario" action="actualizar.php" method="POST">
<input type="hidden" name="accion" value="guardar"> 
(simplifique el código). Eso en principio sería lo correcto, tendrías que recibir todo con $_POST.. ahora cabe la pregunta ¿problemas con ello?, ¿es necesario pasar el valor de "accion" por URL??... ... lo digo porque algúna vez leí en este foro el cómo hacerlo... pero honestamente no lo recuerdo .

Suerte! (espero haya sido ese el error)
__________________
٩(͡๏̯͡๏)۶
» Cómo hacer preguntas de manera inteligente «

"100 años después, la revolución no es con armas, es intelectual y digital"
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 05:32.