Foros del Web » Programando para Internet » PHP »

formulario php

Estas en el tema de formulario php en el foro de PHP en Foros del Web. Muy buenas! tengo un pequeño problema, pero no sé bien a qué es debido. Tengo un formulario simple, en html, como el que sigue: <html> ...
  #1 (permalink)  
Antiguo 19/07/2004, 09:40
 
Fecha de Ingreso: julio-2004
Mensajes: 1
Antigüedad: 13 años, 4 meses
Puntos: 0
formulario php

Muy buenas!

tengo un pequeño problema, pero no sé bien a qué es debido. Tengo un formulario simple, en html, como el que sigue:

<html>
<head>
<title> Prueba </title>
</head>
<body bgcolor= "red">
<table>
<tr>
<td>
<form action="envia_mail.php" method="post">
titulo: <input type=text name="titulo"><br>
cuerpo: <br>
<textarea rows="10" cols="10" name="cuerpo"></textarea>
<input type="submit" value="Enviar">
</form>
</td>
</tr>
</table>
</body>
</html>

Sin embargo, en vez de ejecutar el archivo php "envia_mail.php", lo que hace es sacarme la típica ventana de "abrir archivo o guardar archivo". Y no encuentro la manera de que me ejecute el archivo sin sacarme dicha pantalla.

Espero haberme explicado bien. Muchas gracias ; )
temax.
  #2 (permalink)  
Antiguo 19/07/2004, 10:20
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Y .. donde se supone que estás probando todo esto?

En tu PC? .. (tienes instalado PHP?) .. y ya puestos . .si vas a enviar un e-mail con PHP .(y es tu PC el "servidor") tienes instalado un servidor SMTP en el? o como piensas enviar el e-mail (PHP no envia e-mails .. sólo los "entrega" al MTA que se indique en su configuración: php.ini para que ese tal "MTA" haga su parte)


Un saludo,
  #3 (permalink)  
Antiguo 19/07/2004, 12:25
 
Fecha de Ingreso: abril-2002
Mensajes: 60
Antigüedad: 15 años, 7 meses
Puntos: 0
Bueno, en realidad no tienes un problema exactamente, sino que cuando el formulario envía los datos posteados, referencia al archivo "PHP" y éste PHP no corre sino solamente cuando tienes instalado en tu PC el servidor local de PHP (pues supongo que estás probando). En realidad no hay ningún problema con tu código HTML. Cuando se postea, trata de abrir el PHP porque no lo reconoce como tal. La solución es que instales el servidor local de PHP.
__________________
http://www.autosyautos.com
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 16:18.