Foros del Web » Programando para Internet » PHP »

Frame superior en link no funciona..

Estas en el tema de Frame superior en link no funciona.. en el foro de PHP en Foros del Web. Hola! Estoy tratando de hacer que cuando se de click en un link externo salga el famoso frame arriba como forosdelweb y maestrosdelweb. Tengo esto: ...
  #1 (permalink)  
Antiguo 24/07/2002, 13:00
Avatar de Threepwood  
Fecha de Ingreso: febrero-2002
Ubicación: Argentina
Mensajes: 892
Antigüedad: 15 años, 10 meses
Puntos: 3
Frame superior en link no funciona..

Hola!

Estoy tratando de hacer que cuando se de click en un link externo salga el famoso frame arriba como forosdelweb y maestrosdelweb.
Tengo esto:
*****************************************
CODIGO DE LA PÁGINA CON LOS DOS FRAMES
Cita:
<title>Esta visitando un sitio fuera de AquiComitan.Com.mx</title>
<FRAMESET ROWS="84,*" cols="*" frameborder="no">
<FRAME NAME="arriba" SRC="arriba.php" MARGINWIDTH="10" MARGINHEIGHT="10" SCROLLING="no" FRAMEBORDER="0">
<FRAME NAME="abajo" SRC="="<?php echo $dire; ?>" MARGINWIDTH="10" MARGINHEIGHT="10" SCROLLING="no" FRAMEBORDER="0">
</FRAMESET>
Y para abrir la direccion de un link hago esto:
frame.php?dire=http://www.maestrosdelweb.com

Pero al dar click el fram de arriba (arriba.php) si sale pero donde deberia salir maestrosdelweb.com dice que la página no se encuentra en el servidor!
Hel`p :)
Ya se que no es la mejor manera pero es que ya lo necesito..

Un saludo

<table width="100%" border="0" cellspacing="0" cellpadding="0">
<td bgcolor="#006699"><font color="#FFFF00" size="2" face="Verdana"><center>www.aventurasgraficas.com - [email protected]</center>[/CODE]</td>
</table>
  #2 (permalink)  
Antiguo 24/07/2002, 15:17
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Re: Frame superior en link no funciona..

Esto no es correcto:
SRC=&quot;=&quot;&lt;?php echo $dire; ?&gt;&quot;

Deberia ser:
SRC=&quot;&lt;?php echo $dire; ?&gt;&quot;

Y aqui una variante que uso yo (es lo mismo .. solo varia la forma de trabajar con PHP):

&lt;?
$pagina=$HTTP_GET_VARS['pagina'];
echo &lt;&lt;&lt; HTML
&lt;frameset rows=&quot;80,*&quot; frameborder=&quot;NO&quot; border=&quot;0&quot; framespacing=&quot;0&quot;&gt;
&lt;frame name=&quot;topFrame&quot; scrolling=&quot;NO&quot; noresize src=&quot;http://localhost/php_info.php&quot; &gt;
&lt;frame name=&quot;mainFrame&quot; src=&quot;$pagina&quot;&gt;
&lt;/frameset&gt;
HTML;
?&gt;

Un saludo,
  #3 (permalink)  
Antiguo 24/07/2002, 16:49
Avatar de Threepwood  
Fecha de Ingreso: febrero-2002
Ubicación: Argentina
Mensajes: 892
Antigüedad: 15 años, 10 meses
Puntos: 3
Re: Frame superior en link no funciona..

Gracias Cluster funciona perfecto de las dos fomas

<table width="100%" border="0" cellspacing="0" cellpadding="0">
<td bgcolor="#006699"><font color="#FFFF00" size="2" face="Verdana"><center>www.aventurasgraficas.com - [email protected]</center>[/CODE]</td>
</table>
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 13:28.