Foros del Web » Programando para Internet » PHP »

funcion header()

Estas en el tema de funcion header() en el foro de PHP en Foros del Web. Hola, Tengo una rutina PHP, que al final hace dos cosas: 1.- envia a mi correo 15 datos de un formulario 2.- a continuación abre ...
  #1 (permalink)  
Antiguo 08/10/2007, 06:39
 
Fecha de Ingreso: septiembre-2005
Mensajes: 30
Antigüedad: 14 años, 3 meses
Puntos: 0
Pregunta funcion header()

Hola,

Tengo una rutina PHP, que al final hace dos cosas:

1.- envia a mi correo 15 datos de un formulario
2.- a continuación abre una página nueva y escribe en uno de sus campos uno y sólo uno de los valores del formulario.

Código PHP:
if(!mail($para$sujeto$mensaje$encabezado))
{
    echo 
"<h1>No se pudo procesar la informacion</h1>";
    exit();
}
else
{
    
    
$url "http://misite/la pagina.php?valor=" $dato;
    
    
header("Location: $url");
    
    
}

?> 

pero no funciona.


Aparece una pagina en blanco con la dirección correcta y a continuación en lugar de la variable $dato aparece una porción casi completa de la variable $mensaje que es la que usé para enviarme previamente a mi correo los 15 datos del formulario.

¿Estoy pasando algo por alto? ¿Es la URL absoluta?

Gracias
  #2 (permalink)  
Antiguo 08/10/2007, 19:19
AlvaroG
Invitado
 
Mensajes: n/a
Puntos:
Re: funcion header()

Todo parece correcto. De hecho la URL absoluta es requerida por HTTP 1.1

Pero que todo ande bien en ese trozo no quiere decir que todo esté bien en el programa completo, creo que será necesario que pegues algo más de tu código. Sobretodo el que genera esa variable $dato, y $mensaje.


Saludos.
  #3 (permalink)  
Antiguo 08/10/2007, 19:51
 
Fecha de Ingreso: febrero-2006
Mensajes: 858
Antigüedad: 13 años, 9 meses
Puntos: 4
Re: funcion header()

prueba quitando exit()
__________________
*La amistad se multiplica cuando se divide*
  #4 (permalink)  
Antiguo 11/10/2007, 07:14
 
Fecha de Ingreso: septiembre-2005
Mensajes: 30
Antigüedad: 14 años, 3 meses
Puntos: 0
Re: funcion header()

Había un error en la especificación de la URL y por eso no encontraba la página.

Puedo capturar el valor pasado en un campo oculto pero luego cuando asocio una imagen determinada segun sea ese valor, Firefox da error y no la muestra.
Haré la consulta en el partado correspondiente.

Gracias por la ayuda

Roge
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 19:46.