Foros del Web » Programando para Internet » PHP »

funciona mail no me sale o es la DB

Estas en el tema de funciona mail no me sale o es la DB en el foro de PHP en Foros del Web. Bueno quisiera que me ayuden en esto porque no me sale. y dice asi: http://academia.antorai.com.pe/new/ver?id=contactos ahora la hacer click deberia de procesar y enviar un ...
  #1 (permalink)  
Antiguo 23/08/2002, 16:53
Avatar de ramiro  
Fecha de Ingreso: agosto-2001
Ubicación: PE
Mensajes: 562
Antigüedad: 16 años, 3 meses
Puntos: 0
funciona mail no me sale o es la DB

Bueno quisiera que me ayuden en esto porque no me sale.
y dice asi:

http://academia.antorai.com.pe/new/ver?id=contactos

ahora la hacer click deberia de procesar y enviar un mensaje diciendo que se envio

pero nada no funciona de esa manera? necesariamente debo tener otro archivo?

en lo que hace el proceso el script esta asi.

<?php

$email1="[email protected]";
mail($email1, $nombre, $comentarios, "From: ".$email);
echo "Yu Mensaje Fue enviado Con Exito en breve nos Pondremos en contacto"
?>

cual es el problema a ver si alguien me ayuda.
byes



<center><br>Necesitas Informacion de Cusco -Machupichu?<br><a href="http://www.infocusco.com"><img src="http://www.infocusco.com/machu1.jpg" border="0" alt="Infocusco.com" width="100" height="50"></a></center>
  #2 (permalink)  
Antiguo 23/08/2002, 20:01
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Re: funciona mail no me sale o es la DB

El problema es que no tiene ni pies ni cabeza :P...

Es decir:
haces un .. Enlace (link, refrerncia) .. con una variable .. &quot;id&quot; .. de valor &quot;noseque ..&quot; .. y en el codigo que proporcionas .. solo envia un mail a unas variables q no se sabe si estan o no definidas? ...

Por todo el codigo q uses . o explicate mejor que pretendes hacer ..

Un saludo,

pd: Recuerda, no somos adivinos ..
  #3 (permalink)  
Antiguo 23/08/2002, 21:59
Avatar de ramiro  
Fecha de Ingreso: agosto-2001
Ubicación: PE
Mensajes: 562
Antigüedad: 16 años, 3 meses
Puntos: 0
Re: funciona mail no me sale o es la DB

ok en un campo de la tabla en base de datos tengo lo siguiente:
sin los tags htmls etc..

Código:
 &lt;div align=&quot;center&quot;&gt;&lt;strong&gt;Gracias por el inter&amp;eacute;s de contactar con la Preuniversitaria 
  Antonio Raimondi .&lt;/strong&gt; &lt;/div&gt;
&lt;form  method=&quot;post&quot; action=&quot;ver?id=procesado&amp;n=nombre&amp;m=email&amp;c=comentarios&quot;&gt;
&lt;table width=&quot;350&quot; border=&quot;0&quot; align=&quot;center&quot; cellpadding=&quot;0&quot; cellspacing=&quot;0&quot;&gt;
  &lt;tr&gt;
      &lt;td&gt;&lt;font color=&quot;#000099&quot;&gt;&lt;strong&gt;Nombre&lt;/strong&gt;&lt;/font&gt;&lt;/td&gt;
    &lt;td&gt;
        &lt;input name=&quot;nombre&quot; type=&quot;text&quot; size=&quot;30&quot;&gt;
	&lt;/td&gt;
  &lt;/tr&gt;
  &lt;tr&gt;
      &lt;td height=&quot;24&quot;&gt;&lt;strong&gt;&lt;font color=&quot;#000099&quot;&gt;E-mail&lt;/font&gt;&lt;/strong&gt;&lt;/td&gt;
    &lt;td&gt;&lt;input name=&quot;email&quot; type=&quot;text&quot; size=&quot;30&quot;&gt;&lt;/td&gt;
  &lt;/tr&gt;
  &lt;tr&gt;
      &lt;td&gt;&lt;strong&gt;&lt;font color=&quot;#000099&quot;&gt;Pais&lt;/font&gt;&lt;/strong&gt;&lt;/td&gt;
    &lt;td&gt;&lt;input name=&quot;pais&quot; type=&quot;text&quot; size=&quot;30&quot;&gt;&lt;/td&gt;
  &lt;/tr&gt;
  &lt;tr&gt;
      &lt;td&gt;&lt;font color=&quot;#000099&quot;&gt;&lt;strong&gt;Comentarios&lt;/strong&gt;&lt;/font&gt;&lt;/td&gt;
    &lt;td&gt;&lt;textarea name=&quot;comentarios&quot; cols=&quot;25&quot; rows=&quot;10&quot;&gt;&lt;/textarea&gt;&lt;/td&gt;
  &lt;/tr&gt;
  &lt;tr&gt;
      &lt;td&gt;&amp;nbsp;&lt;/td&gt;
    &lt;td&gt;&lt;input name=&quot;Enviar&quot; type=&quot;submit&quot; value=&quot;Enviar Comentario Ahora&quot;&gt;&lt;/td&gt;
  &lt;/tr&gt;
&lt;/table&gt;&lt;/form&gt;
ahora bien
al hacer click hace referencia a otro campo y ese campo contiene lo siguiente:

Código:
  
&lt;?php

$email1=&quot;[email protected]&quot;
mail($email1, $n, $c, &quot;From: &quot;.$m);
echo &quot;Tu Mensaje Fue enviado Con Exito en breve nos Pondremos en contacto&quot;;
?&gt;

deberia de funcionar?
o no?
a ver si me ayudan mientras voy informandome sobre ello

byes

PD:
hago eso para ya no estar creando otro .php

byes
<center><br>Necesitas Informacion de Cusco -Machupichu?<br><a href="http://www.infocusco.com"><img src="http://www.infocusco.com/machu1.jpg" border="0" alt="Infocusco.com" width="100" height="50"></a></center>
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 16:58.