Foros del Web » Programando para Internet » PHP »

funciones ftp.¿Como hacer que funcionen?

Estas en el tema de funciones ftp.¿Como hacer que funcionen? en el foro de PHP en Foros del Web. Hola a todos, Hace tiempo que tengo una duda a ver si alguien puede contestarme. El caso es que estaba intentando subir archivos a un ...
  #1 (permalink)  
Antiguo 21/04/2005, 05:32
 
Fecha de Ingreso: abril-2005
Mensajes: 2
Antigüedad: 12 años, 7 meses
Puntos: 0
funciones ftp.¿Como hacer que funcionen?

Hola a todos,
Hace tiempo que tengo una duda a ver si alguien puede contestarme.
El caso es que estaba intentando subir archivos a un servidor ftp desde una intranet. Después de darme muchos errores el último este (Warning: Unable to find ftpbuf 0 ) me pasé por el web php.net a buscar info y vi lo siguiente:
Para usar las funciones FTP con su configuración PHP, debe agregar la opción --enable-ftp cuando instale PHP 4, o --with-ftp cuando use PHP 3.

Y yo me pregunto: Si la instalación de php se hizo hace mucho tiempo y en ese momento no tuve en cuenta que iba a usar estas funciones... como se puede solucionar? Habría que volver a ./configure --enable-ftp --enable-blablablabla....

Espero no haberme excedido, pero es una pregunta que me ha surgido en varias ocasiones y no he visto nada al respecto, así que si alguien me puede echar un cable se lo agradecería.

Saludos a todos. y gracias
  #2 (permalink)  
Antiguo 21/04/2005, 09:05
Avatar de sism82  
Fecha de Ingreso: octubre-2003
Ubicación: Guadalajara
Mensajes: 865
Antigüedad: 14 años, 1 mes
Puntos: 1
si no tuvieras soporte para ftp, cualquier función de ftp que uses, te debería indicar:

-- Undefined function

o algo similar. Si tuvieras la amabilidad de poner tu código (el relevante), sería mas sencillo apoyarte. Ahora bien, para agregar soporte para alguna característica de php, como sesiones, ftp, etc. Tienes que recompilar simplemente. Efectivamente, ./configure, con make make install etc etc

un saludo
  #3 (permalink)  
Antiguo 22/04/2005, 07:19
 
Fecha de Ingreso: abril-2005
Mensajes: 2
Antigüedad: 12 años, 7 meses
Puntos: 0
Gracias, ya lo solucioné. El problema era que hacía un include de un fichero de configuración donde definía una constante llamada server. Y en el archivo donde hacía el ftp_put tenía definida la variable server con el nombre del servidor ftp. Por eso me daba problemas.
Pero gracias por la aclaración.
Saludos
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 02:41.