Foros del Web » Programando para Internet » PHP »

Fwrite

Estas en el tema de Fwrite en el foro de PHP en Foros del Web. hola, el siguiente ejemplo de fwrite me sale error interno del servidor, el directorio tiene permiso 777, alguien sabe a que se debe Código PHP: ...
  #1 (permalink)  
Antiguo 07/12/2005, 12:13
 
Fecha de Ingreso: enero-2003
Mensajes: 516
Antigüedad: 14 años, 11 meses
Puntos: 0
Exclamación Fwrite

hola, el siguiente ejemplo de fwrite me sale error interno del servidor, el directorio tiene permiso 777, alguien sabe a que se debe

Código PHP:
<?php
$nombre_archivo 
'prueba.txt';
$contenido "Agregar esto al archivo\n";

// Asegurarse primero de que el archivo existe y puede escribirse sobre el.
if (is_writable($nombre_archivo)) {

   
// En nuestro ejemplo estamos abriendo $nombre_archivo en modo de adicion.
   // El apuntador de archivo se encuentra al final del archivo, asi que
   // alli es donde ira $contenido cuando llamemos fwrite().
   
if (!$gestor fopen($nombre_archivo'a')) {
         echo 
"No se puede abrir el archivo ($nombre_archivo)";
         exit;
   }

   
// Escribir $contenido a nuestro arcivo abierto.
   
if (fwrite($gestor$contenido) === FALSE) {
       echo 
"No se puede escribir al archivo ($nombre_archivo)";
       exit;
   }
   
   echo 
"&Eacute;xito, se escribi&oacute; ($contenido) al archivo ($nombre_archivo)";
   
   
fclose($gestor);

} else {
   echo 
"No se puede escribir sobre el archivo $nombre_archivo";
}
?>
  #2 (permalink)  
Antiguo 07/12/2005, 13:36
 
Fecha de Ingreso: octubre-2004
Mensajes: 751
Antigüedad: 13 años, 2 meses
Puntos: 4
¿Y puedes poner exactamente qué error te está saliendo? Así es posible que si a alguien le pasó lo mismo y supo arreglarlo pueda ayudarte.

En principio no he visto nada raro en el código que pones.

Saludos,
__________________
sergiold
  #3 (permalink)  
Antiguo 07/12/2005, 16:35
Avatar de Seppo  
Fecha de Ingreso: marzo-2005
Ubicación: Buenos Aires, Argentina
Mensajes: 1.284
Antigüedad: 12 años, 8 meses
Puntos: 17
El único posible error que veo es que el archivo que se abre en método "a" no exista... En todo caso pondría a+ en vez de a en el fopen
  #4 (permalink)  
Antiguo 27/06/2006, 06:41
 
Fecha de Ingreso: febrero-2005
Mensajes: 623
Antigüedad: 12 años, 9 meses
Puntos: 10
Tambien tengo el mismo problema y no se porque

Como lo solucionaste?
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 09:48.