Foros del Web » Programando para Internet » PHP »

Hace falta modificar los scripts para adaptarlos al php 5???

Estas en el tema de Hace falta modificar los scripts para adaptarlos al php 5??? en el foro de PHP en Foros del Web. Hola actualmente en mi hosting de pago tienen instalado el php 4.3.9, proximamente van a actualizar al php 5, existe algún problema para que dejen ...
  #1 (permalink)  
Antiguo 29/12/2004, 14:21
 
Fecha de Ingreso: noviembre-2002
Mensajes: 571
Antigüedad: 15 años, 1 mes
Puntos: 2
Hace falta modificar los scripts para adaptarlos al php 5???

Hola actualmente en mi hosting de pago tienen instalado el php 4.3.9, proximamente van a actualizar al php 5, existe algún problema para que dejen de funcionar los scripts o al ser un hosting de pago se supone que las licencias serán completas para interactuar con mysql sin problemas sea la versión del php que sea???

Un saludo.
  #2 (permalink)  
Antiguo 29/12/2004, 15:40
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Usas programación orientada a objetos? .. Bueno .. en general no tienes que hace nada, tus scripts versión 4.x van a funcionar igual en PHP 5.x. Sobre todo si usan Mysql .. asegurate que tu servicio de hosting te habilite mysql_xxx() funciones (extensión) .. pues PHP 5 dispone de otro extensión mejorada para trabajar con Mysql: mysqli_xxx() funciones .. Pueden convivir ambas.

Un saludo,
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 04:33.