Foros del Web » Programando para Internet » PHP »

Hago mal el "rename"?

Estas en el tema de Hago mal el "rename"? en el foro de PHP en Foros del Web. Hola, tengo un pagina con un formulario que sube una imagen al servidor. Cuando sube la imagen quiero renombrarla y ponerle un prefijo antes de ...
  #1 (permalink)  
Antiguo 20/10/2005, 02:48
Avatar de deccweb  
Fecha de Ingreso: febrero-2003
Ubicación: Mataro
Mensajes: 365
Antigüedad: 14 años, 9 meses
Puntos: 0
Hago mal el "rename"?

Hola, tengo un pagina con un formulario que sube una imagen al servidor. Cuando sube la imagen quiero renombrarla y ponerle un prefijo antes de la imagen. Creo que me equivoco el tema comillas " " o puntos... puede ser? o tengo algo mal?


rename("../imagenes/noticias/".$_FILES['imagen']['name'],."../imagenes/noticias/".$pre$_FILES['imagen']['name']);
__________________
Calle17.net

edgargranados.es
  #2 (permalink)  
Antiguo 20/10/2005, 02:54
Avatar de jerkan  
Fecha de Ingreso: septiembre-2005
Mensajes: 1.607
Antigüedad: 12 años, 2 meses
Puntos: 18
Cita:
$_FILES['imagen']['name'],."../imagenes/noticias/"
Me creo de que esa coma y ese punto seguidos no hacen buena compañía. Creo que sobra el punto (que concatena cadenas). Suerte
  #3 (permalink)  
Antiguo 20/10/2005, 03:00
Avatar de deccweb  
Fecha de Ingreso: febrero-2003
Ubicación: Mataro
Mensajes: 365
Antigüedad: 14 años, 9 meses
Puntos: 0
Ya lo he solucionado, os dejo la solución por si alguna persona le pasa el mismo problema que a mi.

rename("../imagenes/noticias/".$_FILES['imagen']['name'],"../imagenes/noticias/$pre".$_FILES['imagen']['name']);
__________________
Calle17.net

edgargranados.es
  #4 (permalink)  
Antiguo 19/05/2006, 17:08
 
Fecha de Ingreso: enero-2002
Mensajes: 265
Antigüedad: 15 años, 10 meses
Puntos: 0
Yo el problema que tengo al renombrar no es ese sino que me da el siguiente error:
Cita:
Warning: rename(Aletia 111.jpg,11480578341.JPG): No such file or directory in /home/www/basquetpetra/admin/publicar.php on line 39
Bien, antes de eso hago un copy (que tb da un error por el estilo). Si le pongo el move_uploaded_file no me da error pero no encuentro despues la imagen en mi server. Sabeis a que se debe? Ese archivo donde ejecuto ese php está en una carpeta admin y yo quiero guardar las fotos en la carpeta FOTOS, un carpeta superior a la de admin :s
El ../fotos no me funciona.
Cualquier comentario sera bueno.
GRACIAS
  #5 (permalink)  
Antiguo 19/05/2006, 17:30
 
Fecha de Ingreso: enero-2002
Mensajes: 265
Antigüedad: 15 años, 10 meses
Puntos: 0
Solucionado! Como:
Cita:
move_uploaded_file ($_FILES['foto']['tmp_name'],'fotos/noticies/'.$fotonueva);
Me va perfecto. Asi, de paso, tb me libro de el rename ya que al moverlo lo guardo con el nombre final que quiero.

Siempre pasa lo mismo, si preguntas buscas la solucion antes que te contesten. Si no lo preguntas tardas horas! Sorry por las molestias...
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 07:38.