Foros del Web » Programando para Internet » PHP »

el httpd.conf del Apache 2.0.39 ¡ Es idferente !

Estas en el tema de el httpd.conf del Apache 2.0.39 ¡ Es idferente ! en el foro de PHP en Foros del Web. He leido varios docs que explican como configurar el Apache pero he encontrado que el archivo httpd.conf es diferente en las versiones 1.3.26 y 2.0.39 ...
  #1 (permalink)  
Antiguo 21/07/2002, 16:32
 
Fecha de Ingreso: julio-2002
Mensajes: 44
Antigüedad: 15 años, 5 meses
Puntos: 0
el httpd.conf del Apache 2.0.39 ¡ Es idferente !

He leido varios docs que explican como configurar el Apache pero he encontrado que el archivo httpd.conf es diferente en las versiones 1.3.26 y 2.0.39 del Apache, esto es, con el PHP 4.2.0 pero aun no logro configurarlo bien.

Alguien que se sepa la configuración del httpd.conf de las versiones más recientes de Apache, se lo agradeceré.

:) :( :) :(
  #2 (permalink)  
Antiguo 22/07/2002, 09:41
 
Fecha de Ingreso: mayo-2002
Mensajes: 106
Antigüedad: 15 años, 6 meses
Puntos: 0
Re: el httpd.conf del Apache 2.0.39 ¡ Es idferente !

Bueno, por lo que veo yo, es que como que estas perdido, define bien lo que quieres hacer, si tan solo lo que quieres configurar es el Apache con PHP ,debes solamente descomentar algunas lineas de httpd.conf y listo (claro que debes primero instalar PHP como modulo o CGI).

Ahora si lo que quieres es como configurar un host virtual en el httpd.conf tengo un link donde muestra como hacerlo.

<a href='ir.asp?http://webmaster.bankhacker.com/php/http.conf.phtml' target='_blank'>http://webmaster.bankhacker.com/php/http...</a>
Instalar Apache+PHP+Mysql
<a href='ir.asp?http://jips.bankhacker.com/linux/apache/ssl/index.phtml' target='_blank'>http://jips.bankhacker.com/linux/apache/...</a>

Si usas Windows
<a href='ir.asp?http://www.webestilo.com/php/php08a.phtml' target='_blank'>http://www.webestilo.com/php/php08a.phtm...</a>

Espero te sirva
Animo..

Senso
<hr>
Vivir para ser libres y bailar ska para ser felices.
  #3 (permalink)  
Antiguo 22/07/2002, 11:53
 
Fecha de Ingreso: julio-2002
Mensajes: 44
Antigüedad: 15 años, 5 meses
Puntos: 0
Re: el httpd.conf del Apache 2.0.39 ¡ Es idferente !

Me pareció un buen link este último, ya lo estoy checando, gracias.
  #4 (permalink)  
Antiguo 22/07/2002, 22:13
 
Fecha de Ingreso: mayo-2002
Ubicación: Mendoza ebria y montañosa
Mensajes: 165
Antigüedad: 15 años, 6 meses
Puntos: 0
Re: el httpd.conf del Apache 2.0.39 ¡ Es idferente !

Güenas, güenas...
ZEONE, andas exactamente con el mismo problema, la ultima version del Apache es diferente, entonces no se pueden seguir los pasos que están en los tutoriales...
Ahora me fijo en esos links que te tiro ahí SENSO (se le agradece notablemente... );
un saludazo,
el chapu
  #5 (permalink)  
Antiguo 22/07/2002, 22:19
 
Fecha de Ingreso: mayo-2002
Ubicación: Mendoza ebria y montañosa
Mensajes: 165
Antigüedad: 15 años, 6 meses
Puntos: 0
Re: el httpd.conf del Apache 2.0.39 ¡ Es idferente !

Acá, de nuevo, ahí estuve viendo los links, lamentablemente no sirven (o por lo menos a mi), los 2 primeros son para linux y el tercero de WebEstilo es viejo...
(tengo Win98)
Si alguien sabe de algo mas reciente, digannos por favor!
chauchas, el chapu
  #6 (permalink)  
Antiguo 22/07/2002, 22:35
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Re: el httpd.conf del Apache 2.0.39 ¡ Es idferente !

A todo esto ... han probado a leer la documentacion oficial de Apache para la version 2.x.x ?¿

<a href='ir.asp?http://httpd.apache.org/docs-2.0/' target='_blank'>http://httpd.apache.org/docs-2.0/...</a>

Un saludo,
  #7 (permalink)  
Antiguo 22/07/2002, 23:13
 
Fecha de Ingreso: mayo-2002
Ubicación: Mendoza ebria y montañosa
Mensajes: 165
Antigüedad: 15 años, 6 meses
Puntos: 0
Re: el httpd.conf del Apache 2.0.39 ¡ Es idferente !

Hey, CLUSTER, estas en todas, no te perdes una vos eh? Lo que pasa es que todas esas explicaciones están en inglés, y yo entiendo lo básico (me defiendo en el tema), pero encima de que no entiendo nada de apache y todo esto de PHP (que es nuevo para mi), el idioma me juega en contra....
es mucho che! no te parece?
continuo mi &quot;extraviación&quot;... necesito ese pastor que me guíe el camino... POR FAVOR!!!
chaito, el chapu
  #8 (permalink)  
Antiguo 23/07/2002, 00:20
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Re: el httpd.conf del Apache 2.0.39 ¡ Es idferente !

Pues .. lo q es yo .. todavia no he probado Apache 2.0 .. sigo con el anterior version y eso si PHP 4.2.1 xD ..

Un saludo,
  #9 (permalink)  
Antiguo 23/07/2002, 00:21
 
Fecha de Ingreso: junio-2002
Mensajes: 186
Antigüedad: 15 años, 6 meses
Puntos: 0
Re: el httpd.conf del Apache 2.0.39 ¡ Es idferente !

Chapu me pasa exactamente lo mismo que a vos!

Si me sale algo te digo. Ya hace varios días que estoy peleando con esto.

Chao <IMG SRC="images/futbol.gif" WIDTH="15" HEIGHT="15" HSPACE="3">

  #10 (permalink)  
Antiguo 23/07/2002, 00:26
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Re: el httpd.conf del Apache 2.0.39 ¡ Es idferente !

jaja esto ya parece un Reto ... a ver quien se anima a instalar Apache 2.xx con PHP 4.2.x .. y hace un &quot;HOW TO&quot; (tutorial paso a paso) xDDD

Un saludo,
  #11 (permalink)  
Antiguo 23/07/2002, 19:48
 
Fecha de Ingreso: mayo-2002
Ubicación: Mendoza ebria y montañosa
Mensajes: 165
Antigüedad: 15 años, 6 meses
Puntos: 0
Re: el httpd.conf del Apache 2.0.39 ¡ Es idferente !

Hola gente amiga, me parece que vamos a terminar instalando el Apache viejo nomás, porque esto ya me tiene mal...
Si algun sabio internauta puede descifrar y contarnos como se instala el Apache 2.0 estaríamos eternamente agradecidos!!!
un saludazo,
el chapu
  #12 (permalink)  
Antiguo 23/07/2002, 22:22
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Re: el httpd.conf del Apache 2.0.39 ¡ Es idferente !

Pero . chapu

Tienes problemas solo con la instalacion de Apache? .. o con PHP sobre Apache?...

Y a todo esto . en que S.O. lo estas instalando .. Linux/windows?

En windows es facil .. casi que a golpe de raton con el instalador que trae ...

Y di donde fallas o que no sabes poner ..

Un saludo,
  #13 (permalink)  
Antiguo 24/07/2002, 14:05
 
Fecha de Ingreso: mayo-2002
Mensajes: 43
Antigüedad: 15 años, 6 meses
Puntos: 0
Re: el httpd.conf del Apache 2.0.39 ¡ Es idferente !

Que bien hace como un mes pregunte esto mismo, insisti tanto que me tacharon de pesado, ahora por lo menos se que no soy el unico....
Pense que apache y php no eran para mi (jijiji), pero ahora se cual es el problema e intentare instalar una version antigua...

Gracias Amigos...
  #14 (permalink)  
Antiguo 24/07/2002, 15:07
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Re: el httpd.conf del Apache 2.0.39 ¡ Es idferente !

A ver Srs. (y Sras. jeje) ...

Apache 2.0.x si leen la documentación, pone bien claro que el soporte para dejar Apache 2.0.x como un servicio de Windows esta en fase Experimental .. asi q si falla .. pues no hay q asustarse ...

Por lo demas funciona perfectamente si lo iniciamos y paramos a mano (desde DOS apache -k start ... y si tienen dundas apache -h que les dará la ayuda ..) .. Por lo demas se instala con su instalador ...

Que problemas hay?

Un saludo,
  #15 (permalink)  
Antiguo 24/07/2002, 20:14
 
Fecha de Ingreso: julio-2002
Mensajes: 44
Antigüedad: 15 años, 5 meses
Puntos: 0
Re: el httpd.conf del Apache 2.0.39 ¡ Es idferente !

Yo instalé el Apache 2.0.x (36) desde FoxServ3Beta2 y todo quedo bien e inicie el Apache con apache -k start pero al darle apache -k stop ni ma...iz palomas, FAILED TO STOP THE APACHE2 SERVICE
y me bloqueo mi maquina y problemas problemas problemas, tuve que instalar el Apache 1.3.x y todo anda bien ahora, hay que chequear bien esa documentacion del Apache 2.0.x ok? por ahí debe estar el eslabon perdido.
  #16 (permalink)  
Antiguo 24/07/2002, 20:18
 
Fecha de Ingreso: julio-2002
Mensajes: 44
Antigüedad: 15 años, 5 meses
Puntos: 0
Re: el httpd.conf del Apache 2.0.39 ¡ Es idferente !

Se me pasaba!!!
El problema NO es instalar Apache 2 en Windows, sino....
CONFIGURAR el httpd.conf para que reconozca al PHP como módulo.
Repito ... el archivo httpd.conf es diferente en esta versión, ni siquiera trae la linea que dice
Código:
clearModuleList
Ni para saber donde ponerle la de ...
Código:
AddModule   etc etc
Opinen...
  #17 (permalink)  
Antiguo 24/07/2002, 21:48
 
Fecha de Ingreso: mayo-2002
Ubicación: Mendoza ebria y montañosa
Mensajes: 165
Antigüedad: 15 años, 6 meses
Puntos: 0
Re: el httpd.conf del Apache 2.0.39 ¡ Es idferente !

Hola amigos!
Antes que nada, les cuento que mi S.O. es Windows98.

Y paso a contarles lo siguiente:
El Apache ya lo instalé; di bastantes vueltas porque había que bajarse tambien un archivo .ssi (para la instalacion), que no tenía idea y que no figuraba en los tutoriales que conocía en ese momento (osea hace unos 4 días), una vez instalado me bajé los archivos de php, de la página php.net, como salía en los manuales, pero descubrí o más bien me econtré con qu venía un &quot;installer&quot;, que tampoco figuraba en los tutoriales, lo instalé desde allí y seguí un par de pasos algunos de los tutoriales y otros de la ayuda que venía con los archivos de php.

Esa ha sido mi historia; pero el problema principal es que no puede configuirar PHP sobre Apache... (va eso me parece...)
Otra cosa que me extraña, en Apache dice: &quot;No services installed&quot;, a qué hace referencia??? php??? windows???? A QUÉ?????

bueno, espero no haberlos mareado, o por lo menos no tanto como los estoy yo,
un saludo,
el chapu
  #18 (permalink)  
Antiguo 24/07/2002, 21:54
 
Fecha de Ingreso: mayo-2002
Ubicación: Mendoza ebria y montañosa
Mensajes: 165
Antigüedad: 15 años, 6 meses
Puntos: 0
Re: el httpd.conf del Apache 2.0.39 ¡ Es idferente !

En conclusión,
se recomienda a todos que si desean instalar el sevidor de Apache, lo hagan a través de una vieja version tal como ZEONE lo hizo:
( Apache 1.3.x )
chau-cha-pu
  #19 (permalink)  
Antiguo 24/07/2002, 23:02
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Re: el httpd.conf del Apache 2.0.39 ¡ Es idferente !

Srs. ... hace unos dias publique un tutorial paso a paso de como instalar PHP 4.2.2 sobre Apache 2.0.x (39 .. lo hice) ..

<a href='ir.asp?http://www.forosdelweb.com/mensaje.asp?id=91700' target='_blank'>http://www.forosdelweb.com/mensaje.asp?i...</a>

Lo leyeron?

Sobre Apache .. al instalarlo .. arranca (y se ponen como autoinicio) la aplicacion de ApacheService Monitor ..). La version 2.0.x tiene dos instalaciones para windows una tal .. msi y otra zip .. La instalacion msi &quot;dice&quot; que deja como servicio a Apache 2.0 .. con lo cual en el ApacheService Monitor deberia aparecer ahi &quot;Apache&quot; corriendo ..
Yo instalae la otra version (la zip) .. y poner Apache como servicio . lo tuve que hacer a mano:
(desde DOS bin/) apache -k install ..
(les recuerdo que si hacen apache -h .. les detalla las operaciones que pueden hacer con apache). Ahi .. al instante .. Apache me salio como servicio en el ApacheService Monitor .. pero no me respondia a los botones de la aplicacion (parar/resetear/iniciar) .. Y .. bueno, leyendo la documentacion de Apache . dice bien claro que la funcion de dejar Apache como servicio en Windows está en fase experimental .. asi q si falla .. pues no lo dejen apache como servicio ..

Yo tambien he vuelvo (en realidad solo me instalá apache 2 por probarlo) .. a la version anterior .. Pero eso no quita que se pueda instalar PHP sobre Apache 2.0.x

Si quieren ver que las modificaciones que hacen a su httpd.conf para instalar un nuevo modulo .. como en este caso es PHP .. ejecuten Apache desde DOS y veran si hay errores ya que los informa (del tipo .. error de sintaxis o lo que toke).

Un saludo,
  #20 (permalink)  
Antiguo 24/07/2002, 23:10
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Re: el httpd.conf del Apache 2.0.39 ¡ Es idferente !

Zeope ..

Apache dos .. gestiona los modulos de otra forma a las versiones anteriores (algo tenian que cambiar?) ... Ahora no hace falta poner nada de lo q mencionas (ni addmodule ni lo otro ) .. Yo asi lo hice como explico en el post q hice el tutorial y me funciono ... Eso si, me di cuenta que no hacia falta por ejemplo el addmodule .. por dos razones: 1) en el httpd.conf no hace mencion a ninguna referencia asi .. 2) la practica xD .. lo puse y ejecute apache desde dos .. ahi me saco Apache un error en esa linea del conf .. se la quite y listo ..
Ahora que alguien de la explicación tecnica de porque no hace falta eso .. blablab bla ... ;)


Un saludo,
  #21 (permalink)  
Antiguo 25/07/2002, 00:19
 
Fecha de Ingreso: mayo-2002
Mensajes: 106
Antigüedad: 15 años, 6 meses
Puntos: 0
Re: el httpd.conf del Apache 2.0.39 ¡ Es idferente !

Para todos hola..

Yo recomiendo que para windows es mejor la version 1.3.26 ya que no es tan complicado instalarlo, porque mucha documentacion vieja se puede aplicar correctamente.

Ahora para las versiones de 2.0 recomiendo que lean el de cluster que esta good.. esto es a decision de ustedes. Yo tambien tuve problemas de ese tipo asi que no se desilucionen..

Nomas he calado el 2.0 en linux, en windows no me he ocupado.

Para los que no entiendan ingles hay un proyecto de Apache en Español, donde se esta traduciendo el manual si lo gustan checar les dejo el link.

<a href='ir.asp?http://quark.fe.up.pt/ApachES/' target='_blank'>http://quark.fe.up.pt/ApachES/...</a>

PD. NO MEJOR :)
PD2. Como reflexion a cluster.. no todos somos expertos, tratamos de aprender...

Senso
<hr>
Vivir para ser libres y bailar ska para ser felices.
  #22 (permalink)  
Antiguo 25/07/2002, 10:46
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Re: el httpd.conf del Apache 2.0.39 ¡ Es idferente !

Senso, yo no soy experto de nada ... solo me gusta la lectura. Tambien .. de lo que leo, lo que no se o entiendo, busco por otro lado que es lo que estoy leyendo y no comprendo .. solo es eso.

Un saludo,
  #23 (permalink)  
Antiguo 25/07/2002, 11:05
 
Fecha de Ingreso: mayo-2002
Mensajes: 106
Antigüedad: 15 años, 6 meses
Puntos: 0
Re: el httpd.conf del Apache 2.0.39 ¡ Es idferente !

Ok..

yo no quiero problemas con nadie, por que creo que todos necesitamos de todos, entiendo que hay gente que lo quiere en bandeja de plata solo para usarse, pero alla ellos eso lo sabemos bien tu y yo cluster.. o no??

Asi que mi intencion no es molestarme o incluso que llegamos a ese tipo de cosas.

Asi que le ofresco disculpas si lo ofendí, y le ofresco un buen trago de refresco( nomas lo compras tu, jaja).

sin rencores?? ...
:)

Senso
<hr>
Vivir para ser libres y bailar ska para ser felices.
  #24 (permalink)  
Antiguo 25/07/2002, 13:20
 
Fecha de Ingreso: julio-2002
Mensajes: 44
Antigüedad: 15 años, 5 meses
Puntos: 0
Re: el httpd.conf del Apache 2.0.39 ¡ Es idferente !

Oye Chapu! también yo tuve ese problema de que NO SERVICES INSTALLED, lo solucioné tecleando:
Código:
apache -k install
y después..
Código:
apache -k start
Todo esto desde MSDOS (directorio bin )
Todo esto fué con el Apache 2.0.x pero en conclusión HAY QUE USAR EL APACHE 1.3.x y dejenme vhevar ese tutorial de Cluster.
  #25 (permalink)  
Antiguo 25/07/2002, 13:23
 
Fecha de Ingreso: julio-2002
Mensajes: 44
Antigüedad: 15 años, 5 meses
Puntos: 0
Re: el httpd.conf del Apache 2.0.39 ¡ Es idferente !

Algo más para los que se inician en esto del PHP...
Bajanse el PHP 4.2.2 porque? lean la información de <a href='ir.asp?http://www.php.net' target='_blank'>http://www.php.net...</a>
RECOMENDADO y además queda bien configurado con el Apache 1.3.x
Saludos y sigamos opinando.....
  #26 (permalink)  
Antiguo 25/07/2002, 14:13
 
Fecha de Ingreso: noviembre-2001
Mensajes: 415
Antigüedad: 16 años, 1 mes
Puntos: 0
Re: el httpd.conf del Apache 2.0.39 ¡ Es idferente !

hace unas 2 o 3 semanas deje un mensaje explicando que la implementacion del ISAPI de apache 2.0.39 era diferente y que el PHP 4.2.1 y menores funcionaba solo como CGI.

Pero encontre la manera de solucionarlo, el tema es que me equivoque y puse PHP 2.4.1 y nadie me dio ni la hora...

veanlo en :
<a href='ir.asp?http://www.forosdelweb.com/mensaje.asp?id=87838' target='_blank'>http://www.forosdelweb.com/mensaje.asp?i...</a>

si no me equivoco cluster hizo otro post explicando lo mismo
  #27 (permalink)  
Antiguo 25/07/2002, 14:14
 
Fecha de Ingreso: noviembre-2001
Mensajes: 415
Antigüedad: 16 años, 1 mes
Puntos: 0
Re: el httpd.conf del Apache 2.0.39 ¡ Es idferente !

Oops, cluster ya habia hablado de lo suyo.

hagan como que no dije nada.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 07:12.