Foros del Web » Programando para Internet » PHP »

Instalando todo para PHP

Estas en el tema de Instalando todo para PHP en el foro de PHP en Foros del Web. Mi pregunta es sencilla, estoy trabajando sobre Windows 2000 con Apache, PHP, MySql y Perl, hasta ahora lo que he hecho es instalar todo con ...
  #1 (permalink)  
Antiguo 27/04/2005, 18:06
Avatar de Neuron_376  
Fecha de Ingreso: abril-2005
Mensajes: 1.051
Antigüedad: 12 años, 8 meses
Puntos: 2
Instalando todo para PHP

Mi pregunta es sencilla, estoy trabajando sobre Windows 2000 con Apache, PHP, MySql y Perl, hasta ahora lo que he hecho es instalar todo con PhpTriad y luego Perl del cual ya tengo la ultima aplicacion para windows.

Mi Pregunta:

1. Liga (preferencia en español) hacia la ultima version de Apache (version release)

2. Liga (preferencia en español) hacia la ultima version de PHP (version release)

3. Liga (preferencia en español) hacia la ultima version de MySql (version release)

Gracias, anexo esto no porque no sepa donde buscar, pero igual quiero saber cual es la version que ustedes usan y por lo tanto es la que saben que no tiene bugs, o bien si tiene alguno, pues es muy, muy raro, en resumen ando en busca de las ultimas versiones pero estables de cada uno.

Gracias.
  #2 (permalink)  
Antiguo 28/04/2005, 08:30
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
1) .. cualquier versión de Apache seríe 2.x
2) .. PHP tienes la línea 4.x y 5.x .. Si vas a trabajar en servidores bajo tu control .. puedes usar si quieres 5.x .. pero si vas a depender en algún momento que tu aplicación tenga que correr en otro servidor que tal vez usen PHP 4.x .. mejor usa PHP 4.x
3) Mysql 4.1.x .. pero todo depende como en el punto 2) si tienes tu el control de tu servidor (siempre o por lo menos para esa aplicación que desarrolles). Sino .. usa Mysql 4.0.x

Todas las versiones tienen "bug" de mayor o menor embergadura los tienen .. de hecho puedes ver como se van corrigiendo y detectando en los "changeLog" de los mismos.

Los links de descarga los tienes en sus respectivas web's oficiales .. y marcadas como versión -estable- (por qué tienes versiones "Release Candidate N°" (RC1 .. RC2 .. ) o versiones Alpha, Beta ... etc.

Un saludo,
  #3 (permalink)  
Antiguo 28/04/2005, 12:23
Avatar de Neuron_376  
Fecha de Ingreso: abril-2005
Mensajes: 1.051
Antigüedad: 12 años, 8 meses
Puntos: 2
Gracias Cluster

Eso es lo que necesitaba saber... pregunta.. la version 5.x de PHP, es estable en este momento ?

Tengo mi propio server para este proyecto entonces si ocupo lo mejor pero tambien lo mas estable.

Otra pregunta, de PHP 4.x (lo uso actualmente) a version 5.x, cuales serian las diferencias importantes?

Mira, he leido mucho de esto, pero es mejor y mas valida ahorita para mi una opinion directa de alguien que ya esta trabajando con esos paquetes y tiene mas experiencia.

Muchas Gracias.
  #4 (permalink)  
Antiguo 28/04/2005, 19:13
Avatar de Neuron_376  
Fecha de Ingreso: abril-2005
Mensajes: 1.051
Antigüedad: 12 años, 8 meses
Puntos: 2
Urgente !!!

Mira, ya baje las ultimas versiones:

PHP 5.0.4
MySql 4.1.11
Apache 2.0.54

Sin embargo parece como que se quieren integrar en el IIS de Windows, y no es lo que yo quiero, o bueno, no se si es la mejor opcion.

Ahorita tengo instalado con phptriad Apache, MySql y PHP, claro, versiones mas viejas, pero funcionales, las cuales no son parte del IIS, sino independientes.

c:\Apache\MySql
c:\Apache\PHP

Y ademas tengo que correr el servidor de apache para hechar a andar el sitio, y eso es lo que quiero seguir manteniendo, porque quiero apagar / borrar el IIS para no tener que soportar dos servidores al mismo tiempo, tambien porque me parece mejor tener PHP y MySql trabajando sobre el apache el cual es su servidor nativo.

Podrías aclararme esa duda, es decir, como le hago para seguir usando mi sistema tal como lo tengo, es decir, simplemente actualizar PHP, Apache y MySql, repetando la funcionalidad actual de mi servidor.

Gracias.
  #5 (permalink)  
Antiguo 29/04/2005, 07:01
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Neuron ..

Debes ver las páginas web oficiales de todo lo mencionado .. Ahí veras por ejemplo que PHP 5.x es estable ya .. pero tiene sus diferencias con PHP 4 aunque siempre la compatibilidad hacia abajo se asegura (ya te hice el comentario de por qué podrías usar una u otra versión para que lo tengas presente).

Por lo demás .. revisa esta guía de instalación de PHP .. cuando veas como se instala PHP + Apache + Mysql .. ahí si quieres seguir respetando tu estructura de directorios de tu instalación .. podras seguirla. De hecho el tutorial menciona un poco com actuar ante actualizaciones. Eso sí .. se enfoca a Mysql 4.0.x y PHP 4.x o 5.x con Apache 2.x (o 1.3.x) abarca todas esas combinaciones de versiones.

Consejo:
Instala PHP 4.x .. Mysql 4.0 (para que sigas la guía tal cual) y Apache 2.x .. Cuando tengas eso claro .. si lo deseas vas probando a instalar PHP 5.x y cambiando a Mysql 4.1 (pero lee los comentarios de ese tutorial . .por qué hay algunos cambios que no abarca dicho tutorial).


http://www.maestrosdelweb.com/editorial/phpmysqlap/

Un saludo,
  #6 (permalink)  
Antiguo 29/04/2005, 10:45
Avatar de Neuron_376  
Fecha de Ingreso: abril-2005
Mensajes: 1.051
Antigüedad: 12 años, 8 meses
Puntos: 2
Gracias.

Bueno, estoy en eso, gracias
  #7 (permalink)  
Antiguo 29/04/2005, 14:54
Avatar de Neuron_376  
Fecha de Ingreso: abril-2005
Mensajes: 1.051
Antigüedad: 12 años, 8 meses
Puntos: 2
Ayuda

Estoy instalando Apache 2.x y no funciona, me dice que no se registro ningun servicio Apache2, y de hecho es cierto, nunca se registro, baje el Windows Installer como lei y lo instale en mi pc porque lei que se necesitaba, entonces no se que otra cosa pueda ser..

Baje un paquete sokkit que si instala correctamente, pero es de paga, y aunque no es mucho, pues prefiero aprender a instalar todo a mano de 0, mi intencion de aprender de 0, es porque realmente estoy esperando la version mas neuva de MySql que soporta trans, store procedures, etc, entonces cuando eso suceda tendre que actualizar a mano mis servidores y no quiero tener que instalar de nuevo todo por un paquete nuevo como sokkit, donde nuevamente tengo que pagar.

Gracias.
  #8 (permalink)  
Antiguo 29/04/2005, 17:06
Avatar de rmilano  
Fecha de Ingreso: abril-2002
Ubicación: Mexico DF
Mensajes: 150
Antigüedad: 15 años, 8 meses
Puntos: 0
Puedes probar ya que veo que utilizas windows una version integrada de algun WAMP (Windows-Apache-MySQL-Php), la que yo uso y me va muy bien es EasyPHP que es francesa la puedes bajar de http://www.easyphp.org/

Saludos y suerte.
__________________
Rodolfo Milano Oliveros
www.todohosting.com.mx
Especialista Sistemas de Información
  #9 (permalink)  
Antiguo 29/04/2005, 17:18
Avatar de Neuron_376  
Fecha de Ingreso: abril-2005
Mensajes: 1.051
Antigüedad: 12 años, 8 meses
Puntos: 2
Gracias..

La estoy probando, gracias.. bueno, por otra parte...

El problema de que no se creo un servicio en mi PC al instalar Apache2, (nota, ya intente con varios ficheors, msi, exe, zip, etc. siempre lo mismo), encontre que el prompt debo correr esto:

apache -k install -n "MyServiceName"

Lo corri, me arroja este error:

Syntax error on line 57 of C:/Apache2
ServerRoot must be a valid directory

Bien, en esa linea existe esto:

ServerRoot "@@[email protected]@"

Esa variable @@[email protected]@ esta por todo el httpd.conf, mi pregunta... que debo poner ahi:

localhost ó c:\Apache2\bin

Asi tengo una serie de variables en todo mi httpd.conf, entonces si alguien tiene una descripcion de todas esas variables pues gracias.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 05:11.