Foros del Web » Programando para Internet » PHP »

Instalar Php commo modulo en APACHE

Estas en el tema de Instalar Php commo modulo en APACHE en el foro de PHP en Foros del Web. Amigos, te ngo un problema, en mi PC (win98), he instalado: Apache 1.3.29 y php 4.3.4. Según los manuales de instalacion de PHP y de ...
  #1 (permalink)  
Antiguo 23/12/2003, 14:57
 
Fecha de Ingreso: diciembre-2003
Ubicación: Chile, Santiago
Mensajes: 8
Antigüedad: 14 años
Puntos: 0
Instalar Php commo modulo en APACHE

Amigos, te ngo un problema, en mi PC (win98), he instalado:
Apache 1.3.29 y php 4.3.4.

Según los manuales de instalacion de PHP y de aplicacion de este como modulo de apache he hecho todas las modificaciones que se necesitan:
- Modificacion del archivo de configuracionde APACHE. (httpd.conf)
- modificacion del archivo de conf. de php (php.ini)

y al iniciar el servidor APACHE

[Tue Dec 23 15:51:43 2003] [warn] (2)No such file or directory:exe() may not be safe
Apache/1.3.29 (Win32) PHP/4.3.4 running...

Al aparecer este esta bien iniciado.
pero al ver a traves de phinfo()
este me muestra aun en el

SERVER API : CGI/FastCGI

cuando creo que este me deberia mostrar Apache.

Que cree que estoy haciendo mal?

de antemano muchas gracias.
GgGStgo
  #2 (permalink)  
Antiguo 23/12/2003, 15:33
Ex Colaborador
 
Fecha de Ingreso: junio-2002
Mensajes: 9.091
Antigüedad: 15 años, 5 meses
Puntos: 16
Hola,

¿Que version de PHP te bajaste? Si era la del instalador para windows (.msi), creo recordar que era solo la version CGI. Si te bajas he instalas el .zip tendrias que poder instalarlo sin problemas.

De todas formas mirate http://www.maestrosdelweb.com/editorial/phpmysqlap/ por si se te ha pasado algo.

Suerte.
__________________
Josemi

Aprendiz de mucho, maestro de poco.
  #3 (permalink)  
Antiguo 23/12/2003, 16:59
 
Fecha de Ingreso: diciembre-2003
Ubicación: Chile, Santiago
Mensajes: 8
Antigüedad: 14 años
Puntos: 0
josemi

muy buena la pagina que indicas, realice las modificaciones. y ahora al correr el phinfo(), efectivamente me indica que como server APACHE.

Pero porque es que las referencias a los directorio se hacen con "/" y no "\".

Pero sabes ahora estoy probando esto:

<html>
<head>
<title>Aprendiendo PHP</title>
<body>
Esta es una página supersimple
<? echo "¿Me aparecerá esta linea?" ?>
</body>
</html>


y al correr esto, no puedo ver el codigo relacionado con php, y el efecto es

"Esta es una página supersimple"

y al revisar el codigo a traves del navegador me muestra el codigo php, no se supone que este codigo no debe aparecer?

de antemano gracias!!!!
  #4 (permalink)  
Antiguo 24/12/2003, 02:29
Ex Colaborador
 
Fecha de Ingreso: junio-2002
Mensajes: 9.091
Antigüedad: 15 años, 5 meses
Puntos: 16
Primero, el fichero debe tener la extension .php

Segundo, debes llamar siempre a las paginas PHP atraves del servidor Apache. Eso quiere decir que en la barra de direcciones debe aparecer algo como http://localhost/pagina.php, nunca algo como c:\dir\pagina.php ni file:/c:\pagina.php. Es decir, nunca des doble click en un PHP y esperes que funcione el codigo PHP.

Doy por supuesto que el apache esta funcionando.

Suerte.

PD: En PHP los separadores de directorios de windows los puedes especificar con /. Mejor para la compatibilidad con linux.
__________________
Josemi

Aprendiz de mucho, maestro de poco.
  #5 (permalink)  
Antiguo 24/12/2003, 09:19
 
Fecha de Ingreso: diciembre-2003
Ubicación: Chile, Santiago
Mensajes: 8
Antigüedad: 14 años
Puntos: 0
josemi,

te agradezco tu ayuda, efectivamente el problema era la extension del archivo.

Gracias
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 20:40.