Foros del Web » Programando para Internet » PHP »

Instalar PHP en PWS

Estas en el tema de Instalar PHP en PWS en el foro de PHP en Foros del Web. Recien estoy iniciandome en esto, los manuales me son de mucha ayuda. Tengo windows 98 SE, y tengo instalado el PWS del cd de windows. ...
  #1 (permalink)  
Antiguo 31/07/2004, 04:26
GPS
 
Fecha de Ingreso: diciembre-2003
Ubicación: Montevideo, Uruguay
Mensajes: 110
Antigüedad: 14 años
Puntos: 0
Instalar PHP en PWS

Recien estoy iniciandome en esto, los manuales me son de mucha ayuda.
Tengo windows 98 SE, y tengo instalado el PWS del cd de windows. las paginas asp me funcionan perfectamente.
El problemas son las php. Instale el php-4.3.4-installer.exe, y configure la carpeta donde tengo las paginas php con la opcion ejecutar en el servidor como indica el manual, pero cuando quiero entrar a una de las paginas me aparece el siguiente mensaje:

Security Alert! The PHP CGI cannot be accessed directly.
This PHP CGI binary was compiled with force-cgi-redirect enabled. This means that a page will only be served up if the REDIRECT_STATUS CGI variable is set, e.g. via an Apache Action directive.

For more information as to why this behaviour exists, see the manual page for CGI security.

For more information about changing this behaviour or re-enabling this webserver, consult the installation file that came with this distribution, or visit the manual page.

¿que significa esto? ¿que es lo que tengo que hacer para solucionarlo?
desde ya muchas gracias
  #2 (permalink)  
Antiguo 31/07/2004, 13:11
 
Fecha de Ingreso: julio-2004
Ubicación: Puerto Vallarta, Jalisco, Mexico
Mensajes: 186
Antigüedad: 13 años, 5 meses
Puntos: 0
ok esto lo saque de otra pagina, pero segun eso tienes que ir a PHP.INI y buscar esto

; cgi.force_redirect is necessary to provide security running PHP as a CGI under
; most web servers. Left undefined, PHP turns this on by default. You can
; turn it off here AT YOUR OWN RISK
; **You CAN safely turn this off for IIS, in fact, you MUST.**
; cgi.force_redirect = 1


y quita la ";" en la ultima linea y cambialo a 0 para que quede asi

cgi.force_redirect = 0

despues reinicia el servidor ( o la PC como quieras) y ya debe de funcionar

si quieres puedes checar este link para ver si no se te paso algo
http://www.devarticles.com/c/a/PHP/I...nal-Web-Server

Suerte
__________________
Shanti Castillo G.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 23:28.