Foros del Web » Programando para Internet » PHP »

Instalcion de Php+Oracle+Apache+FedoraCore3

Estas en el tema de Instalcion de Php+Oracle+Apache+FedoraCore3 en el foro de PHP en Foros del Web. Hola Como Estan, Bueno, primero que todo tengo montado fedora core 3. y estoy intentando instalar Apache 1.3.3 y Php-4.3.11 que es la version que ...
  #1 (permalink)  
Antiguo 15/06/2005, 17:08
 
Fecha de Ingreso: junio-2005
Mensajes: 1
Antigüedad: 12 años, 6 meses
Puntos: 0
Instalcion de Php+Oracle+Apache+FedoraCore3

Hola Como Estan,

Bueno, primero que todo tengo montado fedora core 3. y estoy intentando instalar Apache 1.3.3 y Php-4.3.11 que es la version que tiene soporte para el instant-client de oracle (oci8-instantclient), Apache me instala bien pero cuando ejecuto los siguientes comandos en la carpeta donde tengo los fuentes de php me retorna el sigiente problema.

#./buidconf --force //esto lo hace bien
# ./configure \
--with-oci8-instant-client=/etc/instantclient \
--prefix=$HOME/php --with-apxs=$HOME/apache/bin/apxs \
--enable-sigchild --with-config-file-path=$HOME/apache/conf \
--with-mysql //esto tambien lo hace bien
#make

pero despues de ejecutar el make me retorna el siguiente error.

/usr/bin/ld: cannot find -lirc
collect2: ld returned 1 exit status
make: *** [libphp4.la] Error 1

la verdad no se que significa ni como puedo arreglarlo. y aunque ya lo he buscado no encuentro ninguna guia, tutorial o manual de como solucionarlo.

Agradesco cualquier ayuda que me puedan prestar.
Perdonen la ortografia pero el teclado fisicamente esta en ingles.
  #2 (permalink)  
Antiguo 19/06/2005, 20:36
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
mm Realmente en Fedora con su "yum" es más cómodo (siempre que las versiones de lo que necesites estén dispobibles en sus repositorios oficiales) usarlo.

Por ejemplo

$ yum install apache
.. te instalará Apache 2.x
$ yum install php
... te instalará PHP 4.3.9 (si mal no recuerdo para FC3)

Si quieres soporte Mysql ...(para PHP + Apache):
$ yum install php-mysql (sólo para Mysql 3.23 ... )

Reinicias el servicio httpd (Apache) y tendrás Apache+PHP instalado en cosa de minutos (lo que tardes en bajarte todo).

No sé si estará las extensiones bajo el sistema de RPM's y "yum" para FC3 ..pero nada pierdes intentando:

$ yum install php-oracle

Lo bueno del "yum" es que busca y te instala todas las dependencias (librerías y demás) que te hagan falta.

Eso sí .. si hay alguna versión concreta o algo que no esté en los repositorios oficiales (de rpm's) de la distribución que usas .. si que tendrás que "compilar" a mano PHP y lo que necesites.

Intenta hacer tu pregunta en el foro de Linux para que te orienten mejor y más completo al respecto.

Un saludo,
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 22:00.