Foros del Web » Programando para Internet » PHP »

Les ha pasado?

Estas en el tema de Les ha pasado? en el foro de PHP en Foros del Web. Veamos; Todos sabemos que internet no para de crecer y los lenguajes de programación no paran de desarrollarse, PHP 3, PHP 4... Cuento con varias ...
  #1 (permalink)  
Antiguo 23/07/2003, 05:08
Avatar de ferent  
Fecha de Ingreso: junio-2002
Ubicación: Madrid
Mensajes: 633
Antigüedad: 15 años, 6 meses
Puntos: 0
Les ha pasado?

Veamos;

Todos sabemos que internet no para de crecer y los lenguajes de programación no paran de desarrollarse, PHP 3, PHP 4...

Cuento con varias páginas realizadas bajo este lenguaje, y mi pregunta existencial de hoy es la siguiente:

¿Hoy se utilizan arrays, HTTP_xxx_VARS... pero seguramente en poco tiempo (¿PHP 5.0?) sustitullan estas funciones por otras mucho más elaboradas. Entonces ¿si mi servidor pasara a usar PHP 5.0 ya no funcionarían mis webs?

¿Nunca se quita lo anterior y siempre se añaden cosas nuevas? osease, si hubo (que no lo sé) un PHP 1.0 y yo tubiera realizada mi web bajo ese lenguaje, ¿un servidor con PHP 4.1 lo leería sin problemas?

Esta duda me apareció al leer una FAQ de Cluster en la que afirmaba:
Cita:
Este array $HTTP_xxx_VARS está disponible desde las versiones 4.0.x en adelante y hoy por hoy (ver fecha de la faq) estan habilitadas y se pueden usar .. auque "dicen" q a futuro desaparecera en nuevas versiones de PHP.
__________________
Culto es aquel que sabe donde encontrar lo que no sabe.
  #2 (permalink)  
Antiguo 23/07/2003, 05:59
Ex Colaborador
 
Fecha de Ingreso: junio-2002
Mensajes: 9.091
Antigüedad: 15 años, 5 meses
Puntos: 16
Hola,

Eso de la "compatibilidad hacia atras" a veces es mas un lastre que un beneficio. Fijate en windows. Windows 98 no es mas que un MSDOS con un interfaz grafica. Y ya ves como a poco es mas dificil ejecutar programas DOS en los nuevos Windows.

Segun avanzan las version se van quedando obsoletas ciertas funciones, se añaden funciones nuevas que sustituyen viejas, cambian comportamientos y se modifican los valores por defecto de la configuracion (¿te suena el register_globals?).

Es por esto que en todo desarrollo software el proceso mas caro es el de mantenimiento. Mantenerlo actualizado, solucionando bugs producidos por el cambio del entorno (configuracion, versiones, ...) es una tarea interminable. Tienes dos opciones: o dar soporte de tu script para todas las versiones, modificando lo que haga falta, haciendo que funcione el mismo script en todas, o cada x version, crear "desde cero" otra vez el script, teniendo distintas versiones de tu script para cada una de las versiones de PHP. Normalmente ayuda el planificar para lo peor (siempre que el coste lo permita): pensando que todo puede cambiar, diseñar el script para que los cambios esten localizados y realizar el cambio implique un minimo esfuerzo. Fijate ahora que el PHP5 no incluya MySQL. Todos tus scripts que llamen directamente a funciones MySQL dejaran de funcionar. Pero si has hecho los deberes, en lugar de llamar directamente a esas funciones, habras creado una clase que cree una capa de abstraccion entre tu script y la base de datos. Una clase estilo ADODB. Entonces solo tendrias que cambiar esa clase para que en lugar de usar MySQL use otro motor de base de datos. Que quede claro que es simplemente un ejemplo. Otro ejemplo puede ser la funcion mysql_db_query(). Si la usas el mismo PHP te dice que puede desaparecer en versiones futuras que uses mejor mysql_select_db() y mysql_query().

En fin, hay muchas variables que pueden cambiar. Y cambiaran. Tu solo puedes prepararte lo mejor posible para afrontar ese cambio. Porque el cambio es una constante en el universo.

Saludos.

PD: No me habre puesto demasiado filosofico, ¿verdad?
__________________
Josemi

Aprendiz de mucho, maestro de poco.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 09:54.