Foros del Web » Programando para Internet » PHP »

Libreria GD: no me anda

Estas en el tema de Libreria GD: no me anda en el foro de PHP en Foros del Web. No se que pasa, porque alguna vez me anduvo. Pero desde que volvi a instalar todo, no logre hacer andar el tema de graficos... Exactamente, ...
  #1 (permalink)  
Antiguo 04/03/2003, 14:20
 
Fecha de Ingreso: junio-2002
Ubicación: Buenos Aires, Argentina
Mensajes: 876
Antigüedad: 15 años, 6 meses
Puntos: 0
Libreria GD: no me anda

No se que pasa, porque alguna vez me anduvo. Pero desde que volvi a instalar todo, no logre hacer andar el tema de graficos...
Exactamente, esto fue lo que hice:
*Me baje el php-4.3.1-Win32.zip
*Copie el directorio extensions en c:\php\ (ahi esta php_gd.dll y php_gd2.dll)
*Modifique estas lineas en el php.ini:
extension_dir="c:\php\extensions\"
extension=php_gd.dll (tambien intente con gd2.dll)

Y no me anda, recibo siempre esta advertencia:

PHP Warning: Unable to load dynamic library 'c:\php\extensions\php_gd.dll' - Uno de los dispositivos vinculados al sistema no funciona.

Alguien que me ayude please.
  #2 (permalink)  
Antiguo 04/03/2003, 14:32
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
PHP 4.3.x incorpora una version pre-compilada para esta versión de las librerias GD 2.x

Usa las originales .. y el:
extension_dir="c:\php\extensions\"

no uses el \ final

extension_dir="c:\php\extensions"


Un saludo,
  #3 (permalink)  
Antiguo 04/03/2003, 17:49
 
Fecha de Ingreso: junio-2002
Ubicación: Buenos Aires, Argentina
Mensajes: 876
Antigüedad: 15 años, 6 meses
Puntos: 0
No entiendo lo que decis.
Tengo instalado PHP como CGI y si no hacia eso no existia ningun php_gd.dll
Y olvide mencionarlo, pero ya ahbia probado sin poner el \ al final, y me sale el mismo error.

Alguna idea?
  #4 (permalink)  
Antiguo 05/03/2003, 06:49
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Cuando digo q uses los "originales" es que cada versión de PHP trae sus php_xxx.dll compiladas para esa versión .. Si usas los php_gd.dll de una versión 4.1 por ejemplo en una 4.2 de PHP o al reves PHP da un error similar (o el mismo)..

Si instalastes PHP 4.3.1 sobre los mismos directorios de la anterior versión q tenias .. podría ser que no sustituyeras los antigüos .dll por estos nuevos de la PHP 4.3.1 ..

Un saludo,
  #5 (permalink)  
Antiguo 05/03/2003, 10:00
 
Fecha de Ingreso: junio-2002
Ubicación: Buenos Aires, Argentina
Mensajes: 876
Antigüedad: 15 años, 6 meses
Puntos: 0
Tenes razon Cluster, era eso. Yo tenia la 4.2 y me baje los dll de la 4.3... ya esta solucionado, gracias!
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta

SíEste tema le ha gustado a 1 personas




La zona horaria es GMT -6. Ahora son las 17:29.