Foros del Web » Programando para Internet » PHP »

Librerias GD

Estas en el tema de Librerias GD en el foro de PHP en Foros del Web. Amigos, he tenido que reinicializar todo (Instalacion desde 0 de Linux Konppix) Monte Apache v. 1.3.33 Mysql Pero no tengo las librerias de GD.... ( ...
  #1 (permalink)  
Antiguo 05/10/2005, 13:22
Avatar de gonzalezmfrank  
Fecha de Ingreso: julio-2005
Ubicación: Maracaibo - Venezuela
Mensajes: 266
Antigüedad: 12 años, 4 meses
Puntos: 0
Librerias GD

Amigos, he tenido que reinicializar todo (Instalacion desde 0 de Linux Konppix)

Monte

Apache v. 1.3.33
Mysql

Pero no tengo las librerias de GD.... ( y no consigo la chuleta )

Alguien sabe como instalarlas ?

Las necesito para soluciones generadas en php con imagecreatetruecolor por ejemplo en programa php

Gracias.

Frank
  #2 (permalink)  
Antiguo 05/10/2005, 13:34
 
Fecha de Ingreso: octubre-2005
Mensajes: 365
Antigüedad: 12 años, 2 meses
Puntos: 0
Que version de Php tienes?

Si uno baja generalmente el zip package o los .tar ahí vienen las librerías, osea los archivos .dll

http://www.php.net/downloads.php

Otra opción sería Instaladores, como el EasyPHP (En mi concepto el mejor) y el Appserv (Que le va a la pata), Aquí solo tendrías que descomentar del php.ini la extensión.


http://www.easyphp.org/telechargements.php3

O el AppServ

http://www.appservnetwork.com/
  #3 (permalink)  
Antiguo 05/10/2005, 14:07
Avatar de gonzalezmfrank  
Fecha de Ingreso: julio-2005
Ubicación: Maracaibo - Venezuela
Mensajes: 266
Antigüedad: 12 años, 4 meses
Puntos: 0
Mi version es php4

estoy montando las librerias

apt-get install php4-gd

mil gracias... dejame ver si me funciona

Fran
  #4 (permalink)  
Antiguo 05/10/2005, 14:22
Avatar de gonzalezmfrank  
Fecha de Ingreso: julio-2005
Ubicación: Maracaibo - Venezuela
Mensajes: 266
Antigüedad: 12 años, 4 meses
Puntos: 0
Doesn't work.....

El error que emite es..... en la ejecución ...

Call to undefined function: imagecreatetruecolor()

Que debo hacer.....

Gracias.

Frank
  #5 (permalink)  
Antiguo 05/10/2005, 14:29
 
Fecha de Ingreso: octubre-2005
Mensajes: 365
Antigüedad: 12 años, 2 meses
Puntos: 0
debes descomentar la línea, osea quitarle el ; a la línea

extension=php_gd2.dll

Al archivo php.ini
  #6 (permalink)  
Antiguo 05/10/2005, 15:27
Avatar de gonzalezmfrank  
Fecha de Ingreso: julio-2005
Ubicación: Maracaibo - Venezuela
Mensajes: 266
Antigüedad: 12 años, 4 meses
Puntos: 0
El asunto es que reviso la configuracion de php y lo veo bien.... mi SO es Linux

Alguien me pudiese dar una mano ?

Información de la instalacion php es

http://200.82.232.64:80/pruebas/info.php

Gracias... Frank
  #7 (permalink)  
Antiguo 05/10/2005, 15:40
 
Fecha de Ingreso: octubre-2005
Mensajes: 365
Antigüedad: 12 años, 2 meses
Puntos: 0
Que tal, Yo acabo de Checar my php_info y es practicamente igual al tuyo.

Lo único es que no corresponda la versión de la .dll a la versión de php (Es decir, te bajaste una gd.dll de algún site de Internet?), porque las librerías se compilan para cada versión y tal vez haya una incompatibilidad. no sé.

Si no es eso no sé que mas pueda ser.

Saludos.


También Chequea esto:

http://www.programacion.com/php/tutorial/phpsol_gd/1/
  #8 (permalink)  
Antiguo 05/10/2005, 16:47
Avatar de DvD AdN  
Fecha de Ingreso: mayo-2005
Ubicación: Frente al monitor
Mensajes: 610
Antigüedad: 12 años, 7 meses
Puntos: 0
Si usa Linux, que no se debio haber bajado un gd.so en vez de un gd.dll???
__________________
Keep f***ing learning
Ask for f***ing help.
Use f***ing spell check.
Think about all the f***ing possibilities.
  #9 (permalink)  
Antiguo 05/10/2005, 17:06
Avatar de gonzalezmfrank  
Fecha de Ingreso: julio-2005
Ubicación: Maracaibo - Venezuela
Mensajes: 266
Antigüedad: 12 años, 4 meses
Puntos: 0
Efectivamente la instalación es de una ISO de Linux ( Debian-Knoppix 3.8 ), anteriormente me funcionaba pero en la actualidad, como tuve que arrancar la maquina desde cero no he podido incluir esa funcionalidad (modulo), creo que voy a tener que irme a revisar el CPAM a ver si por alli consigo el módulo

En lo que sepa algo les informo.... si conocen algo de esto por favor indiquenmelo.....

Se que este foro es de PHP y el asunto está más asociado a instalación, pero ,me veo en la necesidad de molestarlos

Saludos

Frank
  #10 (permalink)  
Antiguo 05/10/2005, 17:39
 
Fecha de Ingreso: octubre-2005
Mensajes: 365
Antigüedad: 12 años, 2 meses
Puntos: 0
Ah, no tendrías que "Compilar" php ?
  #11 (permalink)  
Antiguo 06/10/2005, 14:12
Avatar de gonzalezmfrank  
Fecha de Ingreso: julio-2005
Ubicación: Maracaibo - Venezuela
Mensajes: 266
Antigüedad: 12 años, 4 meses
Puntos: 0
Ya resolvi una parte.... al menos caminan ya los

imagecreatetruecolor
imagecolorallocate ......

pero tengo problemas con

imagettftext

al ejecutar el código me devuelve.....

<br />
<b>Warning</b>: imagettftext(): Could not find/open font in <b>/var/www/genera_img.php</b> on line <b>48</b><br />

Que me falta ? para utilizar las funciones de texto...

Saludos

Frank
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 19:41.