Foros del Web » Programando para Internet » PHP »

mail html

Estas en el tema de mail html en el foro de PHP en Foros del Web. ultimamente estoy teniendo problemas con la funcion mail, incluso con ejemplos copiados literalmente del manual, como: <?php $subject = 'Wakeup bob!'; $message = '<b>yo</b>, whassup?'; ...
  #1 (permalink)  
Antiguo 10/07/2006, 13:06
 
Fecha de Ingreso: julio-2003
Ubicación: Buenos Aires
Mensajes: 96
Antigüedad: 14 años, 5 meses
Puntos: 0
mail html

ultimamente estoy teniendo problemas con la funcion mail, incluso con ejemplos copiados literalmente del manual, como:

<?php

$subject = 'Wakeup bob!';
$message = '<b>yo</b>, whassup?';
$headers = "From: [email protected]\r\n" .
'X-Mailer: PHP/' . phpversion() . "\r\n" .
"MIME-Version: 1.0\r\n" .
"Content-Type: text/html; charset=utf-8\r\n" .
"Content-Transfer-Encoding: 8bit\r\n\r\n";

// Send
mail('[email protected]', $subject, $message, $headers);

?>

el mail llega pero es como si no interpretara el codigo html, mostrando:

MIME-Version: 1.0
Content-Type: text/html; charset=utf-8
Content-Transfer-Encoding: 8bit

<b>yo</b>, whassup?

incluso en diferentes clientes de correo, que leen perfectamente mails html. ¿alguna idea de lo que puede ser? gracias.
  #2 (permalink)  
Antiguo 10/07/2006, 13:20
Avatar de Nefertiter  
Fecha de Ingreso: enero-2003
Ubicación: Rosario
Mensajes: 1.316
Antigüedad: 14 años, 11 meses
Puntos: 8
trata de hacerlo tal cual se indica en la primer pagina de las faqs del foro
  #3 (permalink)  
Antiguo 10/07/2006, 13:33
 
Fecha de Ingreso: julio-2003
Ubicación: Buenos Aires
Mensajes: 96
Antigüedad: 14 años, 5 meses
Puntos: 0
perfecto, funciono, muchas gracias. lo que me pregunto es porque a veces los ejemplos funcionan y a veces no ... ¿por el \r? ... no se ... gracias ...
  #4 (permalink)  
Antiguo 10/07/2006, 14:01
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Dependiendo del S.O. del servidor .. así son interpretados los caracteres de "salto de línea" (\n) .. "retorno de carro" (\r) o ambas combinaciones ...

El "standard" sería el \n .. pero windows parece que necesita \n\r y mac sólo \r .. pero como "parece" que los códigos de control que no se reconocen se omiten .. se suele usar \r\n .. (no tengo explicación más teórica al respecto .. pero por ahí va el tema).

Un saludo,
__________________
Por motivos personales ya no puedo estar con Uds. Fue grato haber compartido todos estos años. Igualmente los seguiré leyendo.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 22:46.