Foros del Web » Programando para Internet » PHP »

Migracion de IIS a Apache = session vars!

Estas en el tema de Migracion de IIS a Apache = session vars! en el foro de PHP en Foros del Web. Amigos, El día de hoy instale Apache 1.3.31 ya esta arriba, ya trabaja con php y con mysql. Pero el problema que tengo es que ...
  #1 (permalink)  
Antiguo 20/08/2004, 18:38
 
Fecha de Ingreso: junio-2004
Mensajes: 17
Antigüedad: 13 años, 6 meses
Puntos: 0
Migracion de IIS a Apache = session vars!

Amigos,

El día de hoy instale Apache 1.3.31 ya esta arriba, ya trabaja con php y con mysql. Pero el problema que tengo es que no me esta respetando mis variables de session.

Notice: Undefined index: MM_UserGroup in c:\program files\apache group\apache\htdocs\43.1.0.50.php on line 77

Mi sitio estaba trabajando mmuuuy bien antes del cambio de IIS a Apache, pero ahora con este pequeño detalle esta 'bajo construcción' de nuevo.

¿Me ayudan? ¿Alguna bandera en el php.ini ?

Gracias por estar alli.
  #2 (permalink)  
Antiguo 20/08/2004, 21:50
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
El mensaje de error es un aviso .. Te está informando que no estás programando "correctamente" ...

Deberías tratar las variables externas de tu script (las que llegan de un formulario por POST o GET .. o de un link (GET) .. o son cookies o sesiones entre otras ...) tipo: preguntar si existe (está definida) antes de usarla ..

Ejemplo:

if (isset($_SESSION['variable'])){
// Usas $_SESSION['variable']
}

También se puede controlar PHP para que no dé esos avisos con la directiva (PHP.ini y función de mismo nombre):

error_reporting

Como es normal .. es recomendable que "programes" bien antes de dar soluciones "drásticas" cambiando dicha configuración.

Un saludo,
  #3 (permalink)  
Antiguo 23/08/2004, 17:45
 
Fecha de Ingreso: junio-2004
Mensajes: 17
Antigüedad: 13 años, 6 meses
Puntos: 0
Tal cual lo sospeche y lo mencione en la descripción de mi problema... algo referente a php.ini . Tenia apagada la bandera de register_globals ja! La programación no fue cambiada en lo mas minimo. No era por alli ya que también como lo mencione con IIS funciono por algun tiempo bastante bien. Gracias, por aqui seguimos.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 09:34.