Foros del Web » Programando para Internet » PHP »

Mostrar imagen

Estas en el tema de Mostrar imagen en el foro de PHP en Foros del Web. Tengo este codigo <? mysql_connect("localhost","usario,"contraseña"); $result=mysql_db_query("bd","select * from tabla"); $url1 = "http://www.pagina.com/img/"; echo "<img scr=\"".$url1.$row['imagen']."\">"; ?> al tratar de ver la imagen solo sale un ...
  #1 (permalink)  
Antiguo 16/12/2002, 16:44
Avatar de Salome  
Fecha de Ingreso: noviembre-2002
Ubicación: Colombia
Mensajes: 1.032
Antigüedad: 15 años, 1 mes
Puntos: 1
Mostrar imagen

Tengo este codigo


<?
mysql_connect("localhost","usario,"contraseña");
$result=mysql_db_query("bd","select * from tabla");
$url1 = "http://www.pagina.com/img/";
echo "<img scr=\"".$url1.$row['imagen']."\">";
?>

al tratar de ver la imagen solo sale un cuadrito que no muestra nada.. que puede ser????? :-p
  #2 (permalink)  
Antiguo 16/12/2002, 16:48
Avatar de Manoloweb  
Fecha de Ingreso: enero-2002
Ubicación: Monterrey
Mensajes: 2.454
Antigüedad: 15 años, 10 meses
Puntos: 5
Bueno, puedo ver que te has desesperado en el otro mensaje y estas empezando aqui donde te quedaste.

Esto es lo que pones...

<?
mysql_connect("localhost","usario,"contraseña");
$result=mysql_db_query("bd","select * from tabla");
$url1 = "http://www.pagina.com/img/";
echo "<img scr=\"".$url1.$row['imagen']."\">";
?>


Esto es lo que deberias poner...

<?
mysql_connect("localhost","usario,"contraseña");
$result=mysql_db_query("bd","select * from tabla");
$row=mysql_fetch_array($result);
$url1 = "http://www.pagina.com/img/";
echo "<img scr=\"".$url1.$row['imagen']."\">";
?>


bueno, asumiendo que en tu resultado tengas una campo llamado "imagen"

Te recomiendo una navegada por el manual de PHP en la seccion de mysql.


Saludos
__________________
Manoloweb
  #3 (permalink)  
Antiguo 16/12/2002, 21:38
Avatar de Salome  
Fecha de Ingreso: noviembre-2002
Ubicación: Colombia
Mensajes: 1.032
Antigüedad: 15 años, 1 mes
Puntos: 1
imaginate que ya funciona le hacia falta el row.. claro que ademas de eso tenia mal escrito el codigo html para mostrar la imagen.. es decir no es "<img scr=\""..... es "<img src=\"".
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 04:28.