Foros del Web » Programando para Internet » PHP »

Muy facil para ustedes q son maestros en el tema, para mi un poco complicado

Estas en el tema de Muy facil para ustedes q son maestros en el tema, para mi un poco complicado en el foro de PHP en Foros del Web. hola tengo un pequeño problema para manejar un codigo q maneja plantillas. el codigo es el sgt. <body> <table width="100%" border="0" cellspacing="0" cellpadding="0"> <tr> <td ...
  #1 (permalink)  
Antiguo 27/05/2006, 07:32
 
Fecha de Ingreso: mayo-2006
Mensajes: 4
Antigüedad: 11 años, 6 meses
Puntos: 0
Exclamación Muy facil para ustedes q son maestros en el tema, para mi un poco complicado

hola tengo un pequeño problema para manejar un codigo q maneja plantillas. el codigo es el sgt.



<body>
<table width="100%" border="0" cellspacing="0" cellpadding="0">
<tr>
<td colspan="3"><div align="right">Logotipo y Titulo</div></td>
</tr>
<tr>
<td width="20%"><p>Menu principal</p>
<ul>
<li><a href="?sec=1">Secci&oacute;n 1 </a></li>
<li><a href="?sec=lectura">Secci&oacute;n 2 </a></li>
<li><a href="?sec=insertar">Secci&oacute;n 3 </a></li>
</ul></td>
<td colspan="2" valign="top">
<?php
if(empty($sec))
{
include("insertar.html");
}
else
{
if(file_exists($sec.".php"))
include($sec.".php");
elseif(file_exists($sec.".html"))
include($sec.".html");
else
echo 'Perdón pero la página solicitada no existe';
}
?>
</td>
</tr>
<tr>
<td colspan="3">Pie de p&aacute;gina </td>
</tr>




como veran es bastante simple y funciona perfectamente en local, pero cuando lo subo al server no funciona nada, solo se queda en la pagina principal, si me pudieran ayudar o dar una alternativa les agradeceria
  #2 (permalink)  
Antiguo 27/05/2006, 11:40
 
Fecha de Ingreso: mayo-2004
Mensajes: 34
Antigüedad: 13 años, 6 meses
Puntos: 1
Quizá alguno de los archivos que incluyes no lo tengas aún en el servidor o no lo encuentra. Si te genera un error es muy posible que no lo veas pues usualmente el servidor estará configurado para no mostrarlos. Basta que pongas al principio del script:

Código PHP:
ini_set('display_errors'1); 
Así, cualquier error se mostrará y sabrás por dónde va el problema.

Saludos
  #3 (permalink)  
Antiguo 27/05/2006, 11:49
 
Fecha de Ingreso: mayo-2006
Mensajes: 4
Antigüedad: 11 años, 6 meses
Puntos: 0
variable

estuve haciendo algunas pruebas y nada, al parecer es un problema con la variable que $sec que nunca cambia de estado, siempre se queda en empty, por lo q nunca entra al ciclo, ya trate inicializandola pero tampoco funciona
  #4 (permalink)  
Antiguo 27/05/2006, 18:50
Avatar de jam1138
/** @package Moderador */
 
Fecha de Ingreso: julio-2004
Ubicación: sèveR led onieR lE
Mensajes: 9.368
Antigüedad: 13 años, 4 meses
Puntos: 101
FAQs...

http://www.forosdelweb.com/showthrea...988#post238988
http://www.forosdelweb.com/showthrea...989#post238989

Por favor procura poner títulos descriptivos a los mensajes.

__________________
٩(͡๏̯͡๏)۶
» Cómo hacer preguntas de manera inteligente «

"100 años después, la revolución no es con armas, es intelectual y digital"
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 17:16.