Foros del Web » Programando para Internet » PHP »

MySql

Estas en el tema de MySql en el foro de PHP en Foros del Web. Si tengo mis aplicaciones en MySql 3.23.36 y deseo tener la versión 4.0 que tiene para manejar relaciones y demás.. que implicaciones podria tener sobre ...
  #1 (permalink)  
Antiguo 03/12/2003, 15:33
Avatar de Salome  
Fecha de Ingreso: noviembre-2002
Ubicación: Colombia
Mensajes: 1.032
Antigüedad: 15 años, 1 mes
Puntos: 1
MySql

Si tengo mis aplicaciones en MySql 3.23.36 y deseo tener la versión 4.0 que tiene para manejar relaciones y demás.. que implicaciones podria tener sobre las aplicaciones que tengo??...

Asi mismo tengo php 4.1.2 y deseo actualizarlo.... sufririan cambios mis aplicaciones..??

Saludos..
  #2 (permalink)  
Antiguo 03/12/2003, 21:24
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
Mysql 4.0.x no soporta relaciones (claves foráneas, por lo menos en tablas MyISAM comunes..) .. eso está previsto para Mysql 4.1 (que todavía está en fase Alpha si no me equivoco).

Si has programado aplicaciones que usan Mysql con SQL de las versiones 3.23.36 .. no tendrás ningun problema para migrar hacia versiones 4.0.x de Mysql .. De hecho así lo hice yo y a lo "bruto" moviendo mi directorio "data" (donde Mysql guarda las BD y sus estructuras) "a pelo" sobre mi recien instalado Mysql 4.0.x .. sin problemas.

Los problemas de incompatibilidades .. (a no ser que cambien mucho) suelen ser a la inversa ... es decir .. si tu usas alguna sentencia o metodo de Mysql 4.0.x en una aplicación tuya y luego lo ejecutas en Mysql 3.x.x ahí es donde puedes tener problemas.

Sobre PHP y sus versiones .. lo mismo. En principio no deberían sufir cambios por cambiar la versión de PHP en sí .. Si que veras que si no ajustas igual la configuración (php.ini) de tu nueva versión .. algunas cosas como por ejemplo sesiones (es típico este caso) no se comportarán igual tus aplicaciones. En otros casos .. puede que alguna función que uses esté en "decreap" (en desuso), pero eso ya te lo avisará PHP en un "Notice o Warning" si corresponde.

Los principales problemas de cambiar versión de PHP .. suelen ser como ya mencioné e insito sobre configuración de PHP en sí. Si en su época instalastes PHP 4.1.2 y nunca viste la configuración de tu PHP .. si ahora instalas una versión más reciente . es probable que algunas directivas puedan cambiar de estado por defecto .. por ejemplo .. session.use_trans_sid .. en tu versión actual de PHP está por defecto a 1 ... y en PHP 4.3.x en adelante sale a 0 .. así que si usas sesiones, ahí se pueden comportar diferente tus aplicaciones (=no funcionar como esperabas).

Un saludo,
__________________
Por motivos personales ya no puedo estar con Uds. Fue grato haber compartido todos estos años. Igualmente los seguiré leyendo.
  #3 (permalink)  
Antiguo 04/12/2003, 07:36
Avatar de Salome  
Fecha de Ingreso: noviembre-2002
Ubicación: Colombia
Mensajes: 1.032
Antigüedad: 15 años, 1 mes
Puntos: 1
mmmmmmmm
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 20:05.