Foros del Web » Programando para Internet » PHP »

necesito un charset para caracteres chinos

Estas en el tema de necesito un charset para caracteres chinos en el foro de PHP en Foros del Web. Hola, Estoy haciendo una version en chino, en la base de datos ya se estan almacenando los caracteres correctos, al campo que los contiene le ...
  #1 (permalink)  
Antiguo 27/05/2008, 16:55
 
Fecha de Ingreso: junio-2005
Mensajes: 88
Antigüedad: 14 años, 5 meses
Puntos: 0
necesito un charset para caracteres chinos

Hola,

Estoy haciendo una version en chino, en la base de datos ya se estan almacenando los caracteres correctos, al campo que los contiene le puse el charset gbk_chinese_ci, mientras que en la pagina estoy poniendo con php el header y en html el meta con el mismo charset gbk, pero no me interpreta lo que saca de la base de datos, me lo muestra como ????? mientras que si escribo directamente los caracteres en el html si los interpreta bien, en que parte me estoy jalando, tal vez tengo que hacer algo en el query?

Gracias
  #2 (permalink)  
Antiguo 27/05/2008, 17:10
 
Fecha de Ingreso: abril-2008
Ubicación: Montevideo - Uruguay
Mensajes: 156
Antigüedad: 11 años, 7 meses
Puntos: 5
Respuesta: necesito un charset para caracteres chinos

Hi !

Hace poco tiempo se hizo una web en la empresa donde trabajo y el juego de Caracteres de la base de datos estaba en:
utf8-unicode-ci ( o general, no recuerdo bien)

Y Luego el juego de caracteres de la pagina en UTF-8 ... Y con eso basta, no tienes que especificar el juego de caracteres Chinos.

Espero te sea util!

-ByE-
  #3 (permalink)  
Antiguo 28/05/2008, 10:42
 
Fecha de Ingreso: junio-2005
Mensajes: 88
Antigüedad: 14 años, 5 meses
Puntos: 0
Respuesta: necesito un charset para caracteres chinos

Gracias pero no funciona todavia, me salen ???? no entiendo que pasa, a alguien se le ocurre que puede estar mal?

Gracias
  #4 (permalink)  
Antiguo 06/08/2008, 07:02
 
Fecha de Ingreso: agosto-2008
Mensajes: 1
Antigüedad: 11 años, 4 meses
Puntos: 0
Respuesta: necesito un charset para caracteres chinos

Para solucionar esto tienes que seguir estos pasos......
Yo trabajo con el Dreamweaver, y haciendo lo siguiente me funciona:

•Sustituir la línea (<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">) que aparece en las primeras líneas del código. Por:
<meta HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=chinese">

•Introducir o copiar los caracteres en su lugar correspondiente en modo código.

•Guardar la página en modo Diseño.

•Volver a colocar la etiqueta a <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">

•Guardar la página en modo Diseño.

Tras hacer esto al abrir la página, saldrá con los caracteres correspondientes en modo ASCI por lo que será legible para los chinos..

Espero que te funcione....

SALUDOS
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 16:23.