Foros del Web » Programando para Internet » PHP »

Netscape vs embed+php

Estas en el tema de Netscape vs embed+php en el foro de PHP en Foros del Web. Hola a todos: El problema es que un mp3 no se reproduce en Netscape 7 (no, no me equivoqué de foro ) Lo que pasa ...
  #1 (permalink)  
Antiguo 23/11/2003, 06:53
Avatar de Escoffie  
Fecha de Ingreso: abril-2003
Ubicación: Mérida, Yucatán
Mensajes: 242
Antigüedad: 14 años, 7 meses
Puntos: 9
Netscape vs embed+php

Hola a todos:

El problema es que un mp3 no se reproduce en Netscape 7 (no, no me equivoqué de foro )

Lo que pasa es que el track lo jalo con php de una DB haciendo algo así:

Código PHP:
<embed src="medio.php?idFiles=<?php echo $id;?>"
 width="150" autostart="true" loop="false" 
console="smallconsole" hidden="false"></embed>
... donde medio.php toma el blob y el tipo de archivo etc y lo arma de nuevo (como se hace usualmente con las fotos)

Esto funciona de maravilla en Explorer, pero en Netscape nomás no.

Si le pongo embed a un algo.mp3 y no a medio.php sí funciona en Netscape, de lo cual deduzco que el problema está al leer medio.php y no en la etiqueta embed.

Insisto, en Explorer funciona.

¿Qué podrá ser?

De antemano, gracias
  #2 (permalink)  
Antiguo 23/11/2003, 14:51
Ex Colaborador
 
Fecha de Ingreso: junio-2002
Mensajes: 9.091
Antigüedad: 15 años, 5 meses
Puntos: 16
Hola,

Yo me inclino a que es culpa del Explorer, por ser tan permisivo

Bueno, con el trozo codigo que pones, no te puedo decir mucho. Si pusieras la parte de medio.php donde especificas las cabeceras Content-type: y demas, quizas sea ese el problema.

Saludos.
__________________
Josemi

Aprendiz de mucho, maestro de poco.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 01:38.