Foros del Web » Programando para Internet » PHP »

ni utf8, ni iso... ni nada!

Estas en el tema de ni utf8, ni iso... ni nada! en el foro de PHP en Foros del Web. Que tal [email protected]: Tengo una pagina absoltamente php, donde recibo valores y despues hago algunas consultas a la base de datos con ellos, despues tiene ...
  #1 (permalink)  
Antiguo 17/11/2010, 14:30
Avatar de catpaw  
Fecha de Ingreso: mayo-2010
Ubicación: xalapa
Mensajes: 856
Antigüedad: 9 años, 7 meses
Puntos: 23
ni utf8, ni iso... ni nada!

Que tal [email protected]:

Tengo una pagina absoltamente php, donde recibo valores y despues hago algunas consultas a la base de datos con ellos, despues tiene instrucciones para formular un formato en pdf...todo lo anterior funciona ok...el problema viene al generar el pdf...ya que cualquier acento lo trasforma en caracteres raros...ya se que este tema se a tratado miles de veces pero ya no se por donde atacarlo...probe poniendo al principio del script esta linea:

header('Content-Type: text/html; charset=iso-8859-1');

luego esta

header('Content-Type: text/html; charset=utf-8');

y ni con o sin el header content me arregla los acentos!!

algun consejo?

gracias
  #2 (permalink)  
Antiguo 17/11/2010, 14:38
Avatar de gusma62  
Fecha de Ingreso: julio-2008
Ubicación: Tepatitlán, Jalisco, Mexico
Mensajes: 167
Antigüedad: 11 años, 5 meses
Puntos: 6
Respuesta: ni utf8, ni iso... ni nada!

utf8_decode();
  #3 (permalink)  
Antiguo 17/11/2010, 14:50
Avatar de catpaw  
Fecha de Ingreso: mayo-2010
Ubicación: xalapa
Mensajes: 856
Antigüedad: 9 años, 7 meses
Puntos: 23
Respuesta: ni utf8, ni iso... ni nada!

Cita:
Iniciado por gusma62 Ver Mensaje
utf8_decode();
hola gracias x contesta... y esa la pongo el inicio o q onda?
lo pruebo y les digo


tambien estaba pensando que como en el pdf que se genera saca algunas imagenes podria tener algo que mas con esta linea:

Content-Type: text/html

que con lo otro...sera eso??

gracias

edito agregue: utf8_decode(); al inicio de mi script y tampoco :(
  #4 (permalink)  
Antiguo 17/11/2010, 15:12
 
Fecha de Ingreso: febrero-2010
Mensajes: 818
Antigüedad: 9 años, 10 meses
Puntos: 55
Respuesta: ni utf8, ni iso... ni nada!

$valor = "palabra con caracteres extraños";
echo utf8_decode($valor);
o prueba tambien

htmlspecialchars()
htmlentities()
  #5 (permalink)  
Antiguo 17/11/2010, 15:26
Avatar de catpaw  
Fecha de Ingreso: mayo-2010
Ubicación: xalapa
Mensajes: 856
Antigüedad: 9 años, 7 meses
Puntos: 23
Respuesta: ni utf8, ni iso... ni nada!

que tal ocupe asi:

utf8_decode($NCR=$ccix2['nombre_ceco']);

y no sirvio sigue con caracteres extraños...

ya q no puedo imprimirla con un echo por que se imprime con la libreria para el pdf

probare las demas y les cuento
  #6 (permalink)  
Antiguo 18/11/2010, 02:05
 
Fecha de Ingreso: agosto-2010
Mensajes: 202
Antigüedad: 9 años, 4 meses
Puntos: 4
Respuesta: ni utf8, ni iso... ni nada!

Prueba a poner en el meta
Código HTML:
Ver original
  1. <meta content="text/html; charset=utf-8" http-equiv="Content-Type" />
,

en los registros que tengas en la base de datos, si los tienes almacenados con sus respectivas tildes, al recuperarlos debes de utilizar el echo utf8_decode($valor), si no te funciona prueba el encode. utf8_encode($valor),

saludos!
  #7 (permalink)  
Antiguo 18/11/2010, 06:31
 
Fecha de Ingreso: febrero-2010
Mensajes: 818
Antigüedad: 9 años, 10 meses
Puntos: 55
Respuesta: ni utf8, ni iso... ni nada!

Cita:
Iniciado por catpaw Ver Mensaje
que tal ocupe asi:

utf8_decode($NCR=$ccix2['nombre_ceco']);

y no sirvio sigue con caracteres extraños...

ya q no puedo imprimirla con un echo por que se imprime con la libreria para el pdf

probare las demas y les cuento

utf8_decode($ccix2['nombre_ceco']);
  #8 (permalink)  
Antiguo 18/11/2010, 09:20
Avatar de catpaw  
Fecha de Ingreso: mayo-2010
Ubicación: xalapa
Mensajes: 856
Antigüedad: 9 años, 7 meses
Puntos: 23
Respuesta: ni utf8, ni iso... ni nada!

gracias x su sabiduria chicos!!

ya quedo, le hice asi:

$NCR=utf8_decode($ccix2['nombre_ceco']);

muchas gracias a todos!

Etiquetas: iso, utf
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 08:00.