Foros del Web » Programando para Internet » PHP »

No arranca mi Apache!!!!

Estas en el tema de No arranca mi Apache!!!! en el foro de PHP en Foros del Web. Desde que instale el personal web server para trabajar en otra web (coldfusion), el apache que utilizaba para programar una web en php ha dejado ...
  #1 (permalink)  
Antiguo 10/12/2002, 02:16
 
Fecha de Ingreso: noviembre-2002
Mensajes: 1.135
Antigüedad: 15 años, 1 mes
Puntos: 2
No arranca mi Apache!!!!

Desde que instale el personal web server para trabajar en otra web (coldfusion), el apache que utilizaba para programar una web en php ha dejado de funcionar. El error que me sale es:
"socket operation on non-socket: make_sock for address 0.0.0.0:80, apr_socket_opt_set: (SO_keepalive) no listening sockets available, shutting down.
Unable to open logs"
Se que puede existir un conflicto de puertos, ¿como los cambio? indicarmelo con exactitud por favor. Cual de ellos debo cambiar?
Lo he intentado con Apache, modificando las instrucciones listen 80 -> listen 8080, y UseCanonicalName On -> Off.

gracias
  #2 (permalink)  
Antiguo 10/12/2002, 02:35
 
Fecha de Ingreso: septiembre-2001
Ubicación: Monterrey
Mensajes: 663
Antigüedad: 16 años, 2 meses
Puntos: 6
En tu archivo httpd.conf busca la directiva Port 80 y cambiala por 8080 u otro puerto que este disponible, despue de eso reinicia tu servidor apache.

Con el cambio generado solamente bastara con que acceses a las paginas de la siguiente forma http://host:8080/etc. donde el 8080 es el puerto donde estara escuchando el servidor apache.
  #3 (permalink)  
Antiguo 10/12/2002, 03:48
 
Fecha de Ingreso: noviembre-2002
Mensajes: 1.135
Antigüedad: 15 años, 1 mes
Puntos: 2
No tengo esa directiva ???!!!!

en mi httpd.conf no existe esa directiva, por que?
Tengo la version apache 2.0.4.3

gracias
  #4 (permalink)  
Antiguo 10/12/2002, 04:03
 
Fecha de Ingreso: septiembre-2001
Ubicación: Monterrey
Mensajes: 663
Antigüedad: 16 años, 2 meses
Puntos: 6
Hmmmm. ok haberlo dicho antes, pero no hay problema.
para solucionar el problema solamente tienes que editar la parte que dice Listen 80 y cambiarla por otro puerto algo asi como Listen 0.0.0.0:8080 Recuerda que la directiva va con mayuscula al principio si no te marca error.

Si llegara ha fallar usa dos directivas..
Listen 80
Listen 8080

Pero con una debe de funcionar.
  #5 (permalink)  
Antiguo 10/12/2002, 09:18
 
Fecha de Ingreso: noviembre-2002
Mensajes: 1.135
Antigüedad: 15 años, 1 mes
Puntos: 2
sigue fallandome!!!!

ya no se ke hacer, sigue fallandome con todas las indicaciones ke me habeis dado.
Mirad el error que puse en el primer post a ver si os da alguna pista.

gracias de todas formas.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 08:14.