Foros del Web » Programando para Internet » PHP »

no se conecta a mysql

Estas en el tema de no se conecta a mysql en el foro de PHP en Foros del Web. Hola , tengo PHP 4.3 sobre win xp pro, con apache 2.0.52 y mysql 5 php no se puede conectar a mysql, me da este ...
  #1 (permalink)  
Antiguo 14/12/2004, 23:15
 
Fecha de Ingreso: octubre-2004
Mensajes: 258
Antigüedad: 13 años, 2 meses
Puntos: 1
no se conecta a mysql

Hola , tengo PHP 4.3 sobre win xp pro, con apache 2.0.52 y mysql 5

php no se puede conectar a mysql, me da este error
Warning: mysql_connect(): Client does not support authentication protocol requested by server; consider upgrading MySQL client

es un error mas que conocido, el tema es, donde bajo las actualizaciones?

aparte, cualquier otro que programa como el sqlfront no tiene problemas de conexion, entonces es php 4.3 el que si los tiene.

Bueno, donde bajaria las actualizaciones del cliente para php 4 ?, si es qe este es el camino.

Agradezco cualquier ayuda.
Gracias.
__________________
Salute !!!
RollBack
  #2 (permalink)  
Antiguo 15/12/2004, 05:58
Avatar de spider_boy  
Fecha de Ingreso: diciembre-2003
Ubicación: Chile
Mensajes: 1.855
Antigüedad: 14 años
Puntos: 88
pues no es problema de php, yo tengo el 4.3.9 y no me causa ningun problema... trata de usar una version 4.x de mysql...
  #3 (permalink)  
Antiguo 15/12/2004, 06:54
O_O
 
Fecha de Ingreso: enero-2002
Ubicación: Santiago - Chile
Mensajes: 34.417
Antigüedad: 15 años, 11 meses
Puntos: 126
PHP usa las extensiones para Mysql 4.0.x e inferiores que son las que te ofrecen las funciones: msyql_xxx()

Para Msyql 4.1.x en adelante .. los nuevos "clientes" son las extensiones mysqli_xxxx() .. www.php.net/mysqli .. pero esas extensiones sólo funcionan para PHP 5 ..

Soluciones:
1) Cambias la versión de PHP a la 5 y usas las extensiones mysqli (pero también las mysql para compatibilidad con tus anteriores aplicaciones).

http://www.php.net/mysqli

2) Te quedas como estás .. pero migras tus contraseñas de Mysql al formato antigüo de Mysql 4.x e inferiores.

http://dev.mysql.com/doc/mysql/en/Password_hashing.html

Un saludo,
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 13:09.