Foros del Web » Programando para Internet » PHP »

no consigo configurar php5....

Estas en el tema de no consigo configurar php5.... en el foro de PHP en Foros del Web. hola a ver si me podeis dar la solucion definitiva, me está diciendo estos errores al iniciar la pagina web. php5+mysql 5+ IIS Primero: This ...
  #1 (permalink)  
Antiguo 17/05/2006, 06:40
 
Fecha de Ingreso: noviembre-2002
Mensajes: 1.135
Antigüedad: 15 años, 1 mes
Puntos: 2
no consigo configurar php5....

hola

a ver si me podeis dar la solucion definitiva, me está diciendo estos errores al iniciar la pagina web.
php5+mysql 5+ IIS

Primero:

This PHP CGI binary was compiled with force-cgi-redirect enabled. This means that a page will only be served up if the REDIRECT_STATUS CGI variable is set, e.g. via an Apache Action directive.

For more information as to why this behaviour exists, see the manual page for CGI security.

For more information about changing this behaviour or re-enabling this webserver, consult the installation file that came with this distribution, or visit the manual page.

Segundo:

Fatal error: Call to undefined function mysql_pconnect() in c:\Inetpub\wwwroot\data\xxx.php on line 9

Gracias
  #2 (permalink)  
Antiguo 17/05/2006, 08:26
Avatar de claudiovega  
Fecha de Ingreso: octubre-2003
Ubicación: Puerto Montt
Mensajes: 3.667
Antigüedad: 14 años, 1 mes
Puntos: 11
1) De que forma instalaste php5, que paquete (installer, zip, etc) bajaste?

2) No haz indicado en php.ini que levante la dll de mysql, tienes que ir a la linea que dice:

;extension=php_mysql.dll

y dejarla asi:

extension=php_mysql.dll

Revisar tambien en php.ini que es lo que dice en la linea:

extension_dir =

para saber en que directorio, php esta buscando las extensiones. Dicha linea debe apuntar al directorio donde se encuentre el archivo php_mysql.dll
  #3 (permalink)  
Antiguo 17/05/2006, 08:35
 
Fecha de Ingreso: noviembre-2002
Mensajes: 1.135
Antigüedad: 15 años, 1 mes
Puntos: 2
como estoy probando... y leyendo mogollón de posts... en uno de ellos he leido ke php 5 no merece la pena si no utilizo objetos. Además mi aplicación que está en el servidor, dejaría de funcionar, no?
Bueno, pues he instalado php4, de un instalador, y el error que me da es el siguiente, después de habilitar todo lo que me indicas

Warning: mysql_pconnect(): Client does not support authentication protocol requested by server; consider upgrading MySQL client in c:\inetpub\wwwroot\data\xxx.php on line 9
Client does not support authentication protocol requested by server; consider upgrading MySQL clientPHP Warning: Unknown(): Unable to load dynamic library 'c:\PHP\ext\php_mysql.dll' - No se encontró el proceso especificado. in Unknown on line 0

Gracias
  #4 (permalink)  
Antiguo 17/05/2006, 08:44
Avatar de claudiovega  
Fecha de Ingreso: octubre-2003
Ubicación: Puerto Montt
Mensajes: 3.667
Antigüedad: 14 años, 1 mes
Puntos: 11
1) Los scripts hecho en php4 funcionan en php5, quizá haya alguna que otra excepcion, pero funcionan.

2) mysql_pconnect(): Client does not support authentication protocol requested by server: este error se arregla de varias formas, la más fácil es cambiar la password del usuario usando el metodo antiguo de creacion de password, como se ecplica aqui:

http://www.digitalpeer.com/id/mysql
http://dev.mysql.com/doc/refman/5.0/en/old-client.html
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 20:52.