Foros del Web » Programando para Internet » PHP »

No me corren los archivos php en iexplorer

Estas en el tema de No me corren los archivos php en iexplorer en el foro de PHP en Foros del Web. Perdonad mi ignorancia en el código php, pero tengo toda la web montada y ahora resulta que no me funciona. A ver si algún alma ...
  #1 (permalink)  
Antiguo 19/03/2007, 15:37
 
Fecha de Ingreso: diciembre-2004
Mensajes: 24
Antigüedad: 15 años
Puntos: 0
No me corren los archivos php en iexplorer

Perdonad mi ignorancia en el código php, pero tengo toda la web montada y ahora resulta que no me funciona. A ver si algún alma caritativa me puede ayudar ya que voy a perder en una semana lo conseguido en todo un año.
Resulta que yo siempre he programado en html porque no sé ni tengo tiempo de momento de ponerme con php, sin embargo, obviamente en cuanto mis webs empiezan a tener muchas paginas me resulta imposible actualizarlas todas (como a todo el mundo) intentando remediar esto hize un primer acercamiento a php y me quedé con lo primero que aprendí y con lo que de momento me sirve para facilitarme un poco el trabajo. La función include, de este modo creé mi index con extensión php, pero el único código que lleva el index en php es:
<?
include ("cabecera.html");
?>
<?
include ("menu");
?>
y <?
include ("foot");
?>
suficiente para que ya no me corra la página en iexplorer, en mozilla va perfecto, pero en iexplorer no. No tengo avsolutamente nada más, aperta de estilos css y código html, a qué puede deberse esto.
Una ayudita, por favor. Encarecidamente, estoy muy agobiado con esto.
Gracias por adelantado.
  #2 (permalink)  
Antiguo 19/03/2007, 16:38
Avatar de jcxnet  
Fecha de Ingreso: octubre-2005
Ubicación: Perú
Mensajes: 784
Antigüedad: 14 años, 2 meses
Puntos: 56
Re: No me corren los archivos php en iexplorer

Hola b3co2,
haz la prueba agregándole la directiva php al inicio de la etiqueta, es decir:
Código HTML:
<?
include ("cabecera.html");
?> 
sería
Cita:
<?php
include ("cabecera.html");
?>
haces el cambio y nos comentas,
__________________
►I'm a devil on the run ♂
Jcxnet.com
*Keep It Simple **
  #3 (permalink)  
Antiguo 19/03/2007, 20:27
 
Fecha de Ingreso: septiembre-2006
Ubicación: Buenos Aires
Mensajes: 125
Antigüedad: 13 años, 3 meses
Puntos: 0
Re: No me corren los archivos php en iexplorer

Lo que veo raro es que no pones la extension de los archivos:
menu
foot

otra cosa fijate con IE si podes ver todo el codigo fuente,tal vez tengas un error tonto como una tabla mal configurada.o una etiqueta <xx></xx>
Y un explorador puede solucionar el error dejandote ver la web y el otro no.

Saludos.
  #4 (permalink)  
Antiguo 19/03/2007, 21:56
Avatar de Nefertiter  
Fecha de Ingreso: enero-2003
Ubicación: Rosario
Mensajes: 1.316
Antigüedad: 16 años, 11 meses
Puntos: 9
Re: No me corren los archivos php en iexplorer

Cita:
include ("menu");
tal como dice acknowledge te andaria mejor si pones include 'menu.html';
  #5 (permalink)  
Antiguo 20/03/2007, 01:23
 
Fecha de Ingreso: diciembre-2004
Mensajes: 24
Antigüedad: 15 años
Puntos: 0
Re: No me corren los archivos php en iexplorer

Gracias a todos por contestarme, lo de poner php, ya lo he hecho sin obtener resultado y lo de poner la extension de los archivos ha sido un olvido mío al redactar el post, pero tambien está correcto en el archivo que está colgado en la red, sin embargo no va, lo raro es que con mozilla va perfectamente y en ieplorer no. Y tampoco parece ser problema del servidor. No entiendo nada.
  #6 (permalink)  
Antiguo 20/03/2007, 01:29
 
Fecha de Ingreso: diciembre-2004
Mensajes: 24
Antigüedad: 15 años
Puntos: 0
Re: No me corren los archivos php en iexplorer

Solucionado, era esto -->> para cerrar los estilos css, hay que joderse. Muchas gracias acknowledge por darme la pista.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 01:15.