Foros del Web » Programando para Internet » PHP »

no envia a db

Estas en el tema de no envia a db en el foro de PHP en Foros del Web. tengo este codigo, Código PHP: <?php  $conexion  =  mysql_connect ( "192.168.1.69" , "usuario" , "contraseña" ); // se pilla la conexión mysql_select_db  ( "update" ); // seleccionamos la base de datos $i = 0 ...
  #1 (permalink)  
Antiguo 09/02/2005, 05:09
 
Fecha de Ingreso: noviembre-2003
Ubicación: Barcelona
Mensajes: 181
Antigüedad: 14 años, 1 mes
Puntos: 0
no envia a db

tengo este codigo,
Código PHP:
<?php 
$conexion 
mysql_connect("192.168.1.69","usuario","contraseña");// se pilla la conexión
mysql_select_db ("update");// seleccionamos la base de datos
$i=0;
while(
$i<9){
$i=$i+1;};
while (
$i<9){
$consulta="INSERT INTO pruebas (campo1, campo2, campo3) VALUES ('".$a[$i]."','".$v[$i]."','".$c[$i]."')";
$resultadomysql_query($consulta);
mysql_free_result($resultado);
$i=$i+1;};

mysql_close($conexion);
?>

me vienen unas variables de formulario $a[], $b[], $c[], que sepiten varias veces las tres.


la cuestion, es que por mucho que intento, no se me inserta nada en la base de datos.

no se si veis vosotros alguna fallo, es que lo e intentado casi todo.

un saludo
gracias.
__________________
___________________________

DEL_DAN
  #2 (permalink)  
Antiguo 09/02/2005, 05:11
Avatar de sanjo  
Fecha de Ingreso: enero-2005
Mensajes: 404
Antigüedad: 12 años, 10 meses
Puntos: 0
prueba asi:
<?php
$conexion = mysql_connect("192.168.1.69","usuario","contraseña ");// se pilla la conexión
mysql_select_db ("update");// seleccionamos la base de datos
$i=0;
while($i<9){
$i=$i+1;};
while ($i<9){
$consulta="INSERT INTO pruebas VALUES ('".$a[$i]."','".$v[$i]."','".$c[$i]."')";
$resultado= mysql_query($consulta);
mysql_free_result($resultado);
$i=$i+1;};


?>
  #3 (permalink)  
Antiguo 09/02/2005, 05:27
 
Fecha de Ingreso: noviembre-2003
Ubicación: Barcelona
Mensajes: 181
Antigüedad: 14 años, 1 mes
Puntos: 0
ok gracias.

mi problema estubo en varias cosas, no volvi a poner $i = 0; asi k no se hacia.
además e quitado el mysql_free_result (resutlado); pues me daba error, aun no entiendo muy bie el porke.


gracias.

un saludo
__________________
___________________________

DEL_DAN
  #4 (permalink)  
Antiguo 09/02/2005, 05:27
Avatar de jam1138
/** @package Moderador */
 
Fecha de Ingreso: julio-2004
Ubicación: sèveR led onieR lE
Mensajes: 9.368
Antigüedad: 13 años, 4 meses
Puntos: 101
Cita:
Iniciado por sanjo
$i=0;
while($i<9){
$i=$i+1;};
while ($i<9){
.. tienes $i que vale 0... luego haces un WHILE donde lo incrementas hasta 9... ahora tienes $i=9... en tu siguiente while ya no cumple la condición.
__________________
٩(͡๏̯͡๏)۶
» Cómo hacer preguntas de manera inteligente «

"100 años después, la revolución no es con armas, es intelectual y digital"
  #5 (permalink)  
Antiguo 09/02/2005, 05:28
Avatar de jam1138
/** @package Moderador */
 
Fecha de Ingreso: julio-2004
Ubicación: sèveR led onieR lE
Mensajes: 9.368
Antigüedad: 13 años, 4 meses
Puntos: 101
otra!!!... while(condición) { código }
sin el ;
__________________
٩(͡๏̯͡๏)۶
» Cómo hacer preguntas de manera inteligente «

"100 años después, la revolución no es con armas, es intelectual y digital"
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 17:03.