Foros del Web » Programando para Internet » PHP »

no funciona el link

Estas en el tema de no funciona el link en el foro de PHP en Foros del Web. buenas tardes , el proble que tengo es que tengo una pantalla de consulta en donde me trae los datos pero en el link que ...
  #1 (permalink)  
Antiguo 27/01/2005, 13:22
 
Fecha de Ingreso: enero-2005
Mensajes: 28
Antigüedad: 12 años, 10 meses
Puntos: 0
Exclamación no funciona el link

buenas tardes , el proble que tengo es que tengo una pantalla de consulta en donde me trae los datos pero en el link que sale me deberia llevar a la siguiente paguina con la accion que necesito pero no me esta trayendo nada , la verdad no se que tengo mal sin embargo anexo codigo
//la parte del link
concliente.php
echo "<td align='center'><a style='color:black' href='ModCliente.php?ls_accion=M&nit_cli=".$row["nit_cli"]."'>".$row["nit_cli"]."</a></td>";
// y esta es la parte de de la pantalla modcliente en donde tengo un campo oculto ls_accion
<INPUT type=hidden id=ls_accion name=ls_accion>

ESTO ESTA DENTRO DE UN FORMULARIO DE METODO POST
GRACIAS POR SU AYUDA ANEXO CODIGO

<?php
if ($_POST['ls_accion']=="M")
{
echo "entre a mmmm";
$link=mysql_connect("localhost", "");
mysql_select_db("carros", $link);
$query = "SELECT nit_cli,tid_cli,pas_cli,nom_cli,ape_cli,dep_cli,ci u_cli,dir_cli,tel_cli,fax_cli,ema_cli FROM clientes WHERE nit_cli = ".$_POST['nit_cli'];
$result=mysql_query($query);
if ($result)
{
$num_results = mysql_num_rows($result);
for($i=0; $i<$num_results; $i++)
{

$row = mysql_fetch_array($result);

echo "document.F_FORMA.nit_cli.value = '".$row["nit_cli"]."';";
echo "document.F_FORMA.tid_cli.value = '".$row["tid_cli"]."';";
echo "document.F_FORMA.ape_cli.value = '".$row["nom_cli"]."';";
echo "document.F_FORMA.nom_cli.value = '".$row["ape_cli"]."';";
echo "document.F_FORMA.dir_cli.value = '".$row["dir_cli"]."';";
echo "document.F_FORMA.ciu_cli.value = '".$row["ciu_cli"]."';";
echo "document.F_FORMA.dep_cli.value = '".$row["dep_cli"]."';";
echo "document.F_FORMA.tel_cli.value = '".$row["tel_cli"]."';";
echo "document.F_FORMA.fax_cli.value = '".$row["fax_cli"]."';";
echo "document.F_FORMA.ema_cli.value = '".$row["ema_cli"]."';";
echo "document.F_FORMA.log_cli.value = '".$row["log_cli"]."';";
echo "document.F_FORMA.pas_cli.value = '".$row["pas_cli"]."';";
echo "document.F_FORMA.nit_cli.readOnly = true;";
}
}
}
?>
  #2 (permalink)  
Antiguo 27/01/2005, 13:28
Ex Colaborador
 
Fecha de Ingreso: junio-2002
Mensajes: 9.091
Antigüedad: 15 años, 5 meses
Puntos: 16
Hola,

Un enlace es una peticion GET, no una POST. Y ese enlace no envia el formulario, solo los parametros que le indicas.

Saludos.
__________________
Josemi

Aprendiz de mucho, maestro de poco.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 17:11.