Foros del Web » Programando para Internet » PHP »

no me funciona session_destroy(); en el servidor

Estas en el tema de no me funciona session_destroy(); en el servidor en el foro de PHP en Foros del Web. HOla gente: Tengo el siguiente problema, no me funciona la funcion session_destroy() cuando es ejecutada en el servidor, en mi pc funciona bien: yo inicio ...
  #1 (permalink)  
Antiguo 20/05/2005, 17:59
Avatar de deet  
Fecha de Ingreso: mayo-2005
Ubicación: Córdoba - Argentina
Mensajes: 269
Antigüedad: 12 años, 7 meses
Puntos: 1
no me funciona session_destroy(); en el servidor

HOla gente:

Tengo el siguiente problema, no me funciona la funcion session_destroy() cuando es ejecutada en el servidor, en mi pc funciona bien:
yo inicio sesion asi:

//verificar.php

<?
session_start();
include("conex.php");
$link=conect();
$usuario=$_POST["usuario"];
$clave=$_POST["clave"];
if($usuario!=""){
if($clave!=""){
$sent="select usuario,empresa from usuarios where usuario='$usuario' and clave='$clave' and admin='1'";
$result=mysql_query($sent);
$row=mysql_fetch_array($result);
if($row){
$_SESSION["usuario"]=$row["usuario"];
$_SESSION["empresa"]=$row["empresa"];
header("location:administracion.php");
}else{ header("location:index.php?shwrr=ingrUsrClv");}
}else{ header("location:index.php?shwrr=ingrClvNo");}
}else{ header("location:index.php?shwrr=ingrUsrNo");}
?>

y cierro sesion asi:
//logout.php

<?
session_start();
session_unset();
session_destroy();
?>

una vez que quiero salir de la sesion me da el siguiente error:

Warning: session_destroy(): Session object destruction failed in C:\Domains\transport.com\wwwroot\luxart\admin\logo ut.php on line 4

Ah y tengo otro asunto a solucionar: despues de que el usuario cierre sesion como hago para redireccionarlo p.e. al index.php, ya he intentado poniendo lo siguiente:

<?
session_start();
session_unset();
session_destroy();
header("location:index.php");
?>


pero da error:
Warning: Cannot modify header information - headers already sent by (output started at C:\Domains\transport.com\wwwroot\luxart\admin\logo ut.php:4) in C:\Domains\transport.com\wwwroot\luxart\admin\logo ut.php on line 5


desde ya muchas gracias.
  #2 (permalink)  
Antiguo 21/05/2005, 05:39
Avatar de jam1138
/** @package Moderador */
 
Fecha de Ingreso: julio-2004
Ubicación: sèveR led onieR lE
Mensajes: 9.368
Antigüedad: 13 años, 4 meses
Puntos: 101
.... ¿tienes estas líneas AL INICIO de tu código???
__________________
٩(͡๏̯͡๏)۶
» Cómo hacer preguntas de manera inteligente «

"100 años después, la revolución no es con armas, es intelectual y digital"
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 19:09.